summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Allen2022-07-06 16:03:14 -0700
committerSteven Allen2022-07-06 16:03:14 -0700
commitf68221a4e1269990461eabc2ead5f5672e69beb1 (patch)
tree943a5b2cad6c197c7f951fc2301bedb3b88ec718
parentd0697d2b1665c7ddedae9cff2353de534b1d0238 (diff)
downloadaur-f68221a4e1269990461eabc2ead5f5672e69beb1.tar.gz
update to 1.4.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c03850d77df..d356f43d2e19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
-# Generated by mksrcinfo v8
-# Sat Jan 7 00:15:23 UTC 2017
pkgbase = python-pacparser
pkgdesc = Python 3.x pacparser module
- pkgver = 1.3.7
- pkgrel = 2
- url = https://github.com/pacparser/pacparser
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://github.com/manugarg/pacparser
arch = i686
arch = x86_64
license = LGPL
depends = python>=3.6
options = !makeflags
- source = https://github.com/pacparser/pacparser/archive/1.3.7.tar.gz
- sha256sums = 575c5d8096b4c842b2af852bbb8bcfde96170b28b49f33249dbe2057a8beea13
+ source = https://github.com/manugarg/pacparser/releases/download/v1.4.0/pacparser-v1.4.0.tar.gz
+ sha256sums = 2e66c5fe635cd5dcb9bccca4aced925eca712632b81bada3b63682159c0f910e
pkgname = python-pacparser
-
diff --git a/PKGBUILD b/PKGBUILD
index fba75c1cf10f..7622a21fc6c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,24 @@
# Contributor: Max Meyer <dev@fedux.org>
pkgname='python-pacparser'
-pkgver=1.3.7
-pkgrel=2
+pkgver=1.4.0
+pkgrel=1
arch=(i686 x86_64)
-url="https://github.com/pacparser/pacparser"
+url="https://github.com/manugarg/pacparser"
license=('LGPL')
depends=('python>=3.6')
options=('!makeflags')
pkgdesc="Python 3.x pacparser module"
-source=("https://github.com/pacparser/pacparser/archive/${pkgver}.tar.gz")
-sha256sums=('575c5d8096b4c842b2af852bbb8bcfde96170b28b49f33249dbe2057a8beea13')
+source=("${url}/releases/download/v${pkgver}/pacparser-v${pkgver}.tar.gz")
+sha256sums=('2e66c5fe635cd5dcb9bccca4aced925eca712632b81bada3b63682159c0f910e')
build() {
- cd pacparser-$pkgver
+ cd "pacparser-v${pkgver}"
PYTHON=python3 make all pymod -C src
}
package() {
-
- cd pacparser-$pkgver
+ cd "pacparser-v${pkgver}"
PYTHON=python3 make -C src DESTDIR="$pkgdir/" install-pymod
}