summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2018-04-20 00:50:22 -0400
committerclintval2018-04-20 00:50:22 -0400
commitc1193c821595c71a37339f7a4bbe7d6be470619f (patch)
tree66c2a57ffe6dce3f24b645cffe782f150e225b81
parent1b90fa4472625e6227f78ad281bcb1a65aad4995 (diff)
downloadaur-c1193c821595c71a37339f7a4bbe7d6be470619f.tar.gz
python-palettable to 3.1.0
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD70
2 files changed, 53 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc8e2eb30c53..d0ca70adbd70 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,26 @@
-# Generated by mksrcinfo v8
-# Tue May 2 15:01:58 UTC 2017
pkgbase = python-palettable
pkgdesc = Color palettes for Python
- pkgver = 3.0.0
+ pkgver = 3.1.0
pkgrel = 1
- url = https://jiffyclub.github.io/palettable/
+ url = https://pypi.org/project/palettable
arch = any
license = MIT
+ makedepends = python
+ makedepends = python-setuptools
+ makedepends = python2
+ makedepends = python2-setuptools
replaces = python-brewer2mpl
- source = https://pypi.python.org/packages/31/6c/d95417ead6f8d9fc8ae0d6fbb76fb4107ced7ca949c96a3604bb2d23c401/palettable-3.0.0.tar.gz
- md5sums = 6e430319fe01386c81dbbc62534e3cc4
+ options = !emptydirs
+ source = python-palettable-3.1.0.tar.gz::https://pypi.io/packages/source/p/palettable/palettable-3.1.0.tar.gz
+ source = https://raw.githubusercontent.com/jiffyclub/palettable/d267e4aa8f746ab800d4998e670d60eca13f32cd/license.txt
+ sha256sums = 4c6f6531b93d97eb0bf4d707160626261de11470c47e2d017ac6bb569b5308aa
+ sha256sums = 06982353629cfa6b7b339fa4cfccd6eca5a4434d5caefb7c32e68baa41a1be7c
pkgname = python-palettable
depends = python
depends = python-matplotlib
+pkgname = python2-palettable
+ depends = python2
+ depends = python2-matplotlib
+
diff --git a/PKGBUILD b/PKGBUILD
index 615377d3b3b0..e973e9fc66e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,53 @@
-# Maintainer: Kyle Meyer <kyle@kyleam.com>
-# https://github.com/kyleam/maint-aur
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+# Contributer: Kyle Meyer <kyle@kyleam.com>
-pkgname=python-palettable
-# To build and install the python 2 package as well, use the next line
-# instead of the above one.
-# pkgname=('python-palettable' 'python2-palettable')
-
-_libname=${pkgname/python-/}
-pkgver=3.0.0
+_name=palettable
+pkgbase='python-palettable'
+pkgname=('python-palettable' 'python2-palettable')
+pkgver=3.1.0
pkgrel=1
-pkgdesc='Color palettes for Python'
+pkgdesc="Color palettes for Python"
arch=('any')
-url='https://jiffyclub.github.io/palettable/'
+url=https://pypi.org/project/palettable
license=('MIT')
-
+makedepends=(
+ 'python' 'python-setuptools'
+ 'python2' 'python2-setuptools')
+options=(!emptydirs)
replaces=('python-brewer2mpl')
+source=(
+ "${pkgname}"-"${pkgver}".tar.gz::https://pypi.io/packages/source/"${_name:0:1}"/"${_name}"/"${_name}"-"${pkgver}".tar.gz
+ https://raw.githubusercontent.com/jiffyclub/palettable/d267e4aa8f746ab800d4998e670d60eca13f32cd/license.txt
+)
+sha256sums=(
+ '4c6f6531b93d97eb0bf4d707160626261de11470c47e2d017ac6bb569b5308aa'
+ '06982353629cfa6b7b339fa4cfccd6eca5a4434d5caefb7c32e68baa41a1be7c'
+)
+
+prepare() {
+ cp -a "${_name}"-"${pkgver}"{,-py2}
+}
-source=("https://pypi.python.org/packages/31/6c/d95417ead6f8d9fc8ae0d6fbb76fb4107ced7ca949c96a3604bb2d23c401/palettable-3.0.0.tar.gz")
-md5sums=('6e430319fe01386c81dbbc62534e3cc4')
+build(){
+ cd "${srcdir}"/"${_name}"-"${pkgver}"
+ python setup.py build
-build() {
- cd "$srcdir/$_libname-$pkgver"
+ cd "${srcdir}"/"${_name}"-"${pkgver}"-py2
+ python2 setup.py build
+}
- rm -rf ../buildpy3; mkdir ../buildpy3
- python setup.py build -b ../buildpy3
+package_python2-palettable() {
+ depends=('python2' 'python2-matplotlib')
- ## python 2 build
- if [ ${#pkgname[@]} -eq 2 ]; then
- rm -rf ../buildpy2; mkdir ../buildpy2
- python2 setup.py build -b ../buildpy2
- fi
+ install -Dm644 license.txt "${pkgdir}"/usr/share/licenses/"${pkgname}"/license.txts
+ cd "${_name}"-"${pkgver}"-py2
+ python2 setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
}
package_python-palettable() {
depends=('python' 'python-matplotlib')
- cd "$srcdir/$_libname-$pkgver"
- rm -rf build; ln -s ../buildpy3 build
- python setup.py install --skip-build -O1 --root="$pkgdir"
-}
-package_python2-palettable() {
- depends=('python2' 'python2-matplotlib')
- cd "$srcdir/$_libname-$pkgver"
- rm -rf build; ln -s ../buildpy2 build
- python2 setup.py install --skip-build -O1 --root="$pkgdir"
+ install -Dm644 license.txt "${pkgdir}"/usr/share/licenses/"${pkgname}"/license.txts
+ cd "${_name}"-"${pkgver}"
+ python setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
}