summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Doppler2017-04-17 11:21:08 +0200
committerSimon Doppler2017-04-17 11:21:08 +0200
commit3ac7f842a1d70699b0b3de689528cc09565e6560 (patch)
treef868040340da37ffec95aabdaf5e7b9d9487d255
downloadaur-3ac7f842a1d70699b0b3de689528cc09565e6560.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7890f43a9101
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Mon Apr 17 09:20:57 UTC 2017
+pkgbase = python-pam-git
+ pkgdesc = Python pam module supporting py3 (and py2)
+ pkgver = r31.583cfe7
+ pkgrel = 1
+ url = https://github.com/FirefighterBlu3/python-pam
+ arch = any
+ license = MIT
+ depends = python
+ source = git+https://github.com/FirefighterBlu3/python-pam
+ sha256sums = SKIP
+
+pkgname = python-pam-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..758772949008
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer : Simon Doppler <dop dot simon at gmail dot com>
+
+_projname=python-pam
+_user=FirefighterBlu3
+pkgname=${_projname}-git
+pkgver=r31.583cfe7
+pkgrel=1
+pkgdesc='Python pam module supporting py3 (and py2)'
+arch=('any')
+url="https://github.com/${_user}/${_projname}"
+license=('MIT')
+depends=('python')
+source=("git+https://github.com/${_user}/${_projname}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${_projname}
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ${_projname}
+ python setup.py install --root="$pkgdir"
+ install -d "$pkgdir/usr/share/licenses/python-pam-git"
+ install -D LICENSE "$pkgdir/usr/share/licenses/python-pam-git"
+}
+