summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2015-10-22 22:10:04 +0200
committerMichel Zou2015-10-22 22:10:04 +0200
commit9a1646ca2fea0e4f1c741f2ae6efa59c9dcf8ae8 (patch)
treea448ee4582d132c7d2cb695b35d38d6ef2961059
downloadaur-9a1646ca2fea0e4f1c741f2ae6efa59c9dcf8ae8.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD16
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee384f926dde
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pamela
+ pkgdesc = Python PAM interface
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/minrk/pamela
+ arch = any
+ license = MIT
+ depends = pam
+ depends = python
+ source = https://github.com/minrk/pamela/archive/0.2.1.tar.gz
+ md5sums = b8a302b41cfc62912e467fc389d7ceb3
+
+pkgname = python-pamela
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be5053142b08
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+pkgname=python-pamela
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="Python PAM interface"
+arch=('any')
+url="https://github.com/minrk/pamela"
+license=('MIT')
+depends=('pam' 'python')
+source=("https://github.com/minrk/pamela/archive/${pkgver}.tar.gz")
+md5sums=('b8a302b41cfc62912e467fc389d7ceb3')
+
+package() {
+ cd "$srcdir/pamela-$pkgver"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+