summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Ostuni2019-08-16 18:58:59 +0200
committerDario Ostuni2019-08-16 18:58:59 +0200
commit2bdfe4d13f2dba4e73470e915753a8c1033d4692 (patch)
tree096d64e8ab737bca6351f00457000ec865ecde02
downloadaur-2bdfe4d13f2dba4e73470e915753a8c1033d4692.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..45287a432fcc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pampy
+ pkgdesc = The Pattern Matching for Python you always dreamed of
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/santinic/pampy
+ arch = any
+ license = MIT
+ depends = python
+ options = !emptydirs
+ source = pampy-0.2.1::git+https://github.com/santinic/pampy.git#commit=27de362e63310eaa5044c7c87414d19aacefef56
+ sha384sums = SKIP
+
+pkgname = python-pampy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f74c6a056ae4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Dario Ostuni <another.code.996@gmail.com>
+pkgname=python-pampy
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="The Pattern Matching for Python you always dreamed of"
+arch=('any')
+url="https://github.com/santinic/pampy"
+license=('MIT')
+depends=('python')
+options=(!emptydirs)
+#source=("https://github.com/santinic/pampy/archive/v${pkgver}.tar.gz")
+source=("pampy-${pkgver}::git+https://github.com/santinic/pampy.git#commit=27de362e63310eaa5044c7c87414d19aacefef56")
+sha384sums=('SKIP')
+
+package() {
+ cd "$srcdir/pampy-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}