summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2020-03-13 19:25:55 +0200
committerStelios Tsampas2020-03-13 19:25:55 +0200
commitf2b1db3e827c29cf6a6da4d1d10086e1df7ac459 (patch)
tree2257ad0b1c4ca332db6414d1f929021bcc25f473
downloadaur-f2b1db3e827c29cf6a6da4d1d10086e1df7ac459.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd72711ba1db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-pandasvault-git
+ pkgdesc = Advanced Pandas Vault — Utilities, Functions and Snippets.
+ pkgver = 0.r74.53e7077
+ pkgrel = 1
+ url = https://github.com/firmai/pandasvault
+ arch = x86_64
+ license = MIT
+ makedepends = python
+ depends = python-pandas
+ depends = python-numpy
+ depends = python-scikit-learn
+ depends = python-setuptools
+ provides = python-pandasvault
+ conflicts = python-pandasvault
+ source = pandasvault::git+https://github.com/firmai/pandasvault.git
+ sha256sums = SKIP
+
+pkgname = python-pandasvault-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..14251e32699e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: loathingkernel <username ta gmail tod com>
+
+pkgname=python-pandasvault-git
+pkgver=0.r74.53e7077
+pkgrel=1
+pkgdesc="Advanced Pandas Vault — Utilities, Functions and Snippets."
+arch=('x86_64')
+url="https://github.com/firmai/pandasvault"
+license=('MIT')
+depends=('python-pandas' 'python-numpy' 'python-scikit-learn' 'python-setuptools')
+makedepends=('python')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("pandasvault::git+https://github.com/firmai/pandasvault.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "$srcdir"/pandasvault
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+build() {
+ cd "$srcdir"/pandasvault
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir"/pandasvault
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ #install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}