summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulien Nicoulaud2017-09-12 19:43:59 +0200
committerJulien Nicoulaud2017-09-12 19:43:59 +0200
commit8e83102c73a164af2c25905a1d9759b7e81c3e6b (patch)
tree786e4c7869d6a6922e62c5625ae9c88721a94970
parentd7c94d37b8696f739f6fd1bf236da22dd5e4954f (diff)
downloadaur-8e83102c73a164af2c25905a1d9759b7e81c3e6b.tar.gz
Add missing dependency
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c6033bea61e..8c7a1e5d6912 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pandoc-imagine
pkgdesc = Imagine is a pandoc filter that will turn codeblocks tagged with certain classes into images or ascii art..
pkgver = 0.1.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/hertogp/imagine
arch = any
license = MIT
@@ -13,6 +13,8 @@ pkgbase = python-pandoc-imagine
sha512sums = d23742823efd5ee9f797b197d7751592e01ed14cd01f99ba11046b8585bb43a5080043541f2152eb7b1e74a65b81c3416d38a9f7dd03321594a8f08e6940a63e
pkgname = python-pandoc-imagine
+ depends = python-pandocfilters>=1.4
pkgname = python2-pandoc-imagine
+ depends = python2-pandocfilters>=1.4
diff --git a/PKGBUILD b/PKGBUILD
index 412b40da6948..b697b32d9a6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgname=pandoc-imagine
pkgbase="python-${_pkgname}"
pkgname=("python-${_pkgname}" "python2-${_pkgname}")
pkgver=0.1.5
-pkgrel=1
+pkgrel=2
arch=('any')
license=('MIT')
pkgdesc="Imagine is a pandoc filter that will turn codeblocks tagged with certain classes into images or ascii art.."
@@ -26,11 +26,15 @@ build() {
}
package_python-pandoc-imagine() {
+ depends=('python-pandocfilters>=1.4')
+
cd pandoc-imagine-$pkgver
python setup.py install --root="$pkgdir" --optimize=1
}
package_python2-pandoc-imagine() {
+ depends=('python2-pandocfilters>=1.4')
+
cd pandoc-imagine-$pkgver-py2
python2 setup.py install --root="$pkgdir" --optimize=1