summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2019-03-01 15:18:57 +0000
committerCaleb Maclennan2019-03-01 15:18:57 +0000
commit1d8fd1f504e36fc296cbd80e15dac87c67abaf3e (patch)
tree6bf60370d3ae53098a99889de892c185e484940e
downloadaur-1d8fd1f504e36fc296cbd80e15dac87c67abaf3e.tar.gz
Init: pipman pandoc-include
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a5f32721d43a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python-pandoc-include
+ pkgdesc = Panflute filter to allow file includes
+ pkgver = 0.3.2
+ pkgrel = 1
+ url = https://github.com/DCsunset/pandoc-include
+ arch = any
+ license = MIT
+ makedepends = python
+ makedepends = python-pip
+
+pkgname = python-pandoc-include
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7cb1332f527
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# PKGBUILD generated by pipman
+# Python package author: DCsunset <DCsunset@protonmail.com>
+pkgname=python-pandoc-include
+pkgver=0.3.2
+pkgrel=1
+pkgdesc="Panflute filter to allow file includes"
+arch=(any)
+url="https://github.com/DCsunset/pandoc-include"
+license=(MIT)
+makedepends=("python" "python-pip")
+build() {
+ pip install --no-deps --target="pandoc-include" pandoc-include==0.3.2
+}
+package() {
+ sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
+ mkdir -p $pkgdir/"$sitepackages"
+ cp -r $srcdir/pandoc-include/* $pkgdir/"$sitepackages"
+} \ No newline at end of file