summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2019-11-15 13:46:18 +0300
committerCaleb Maclennan2019-11-15 13:46:18 +0300
commit2577aa7fd0f86e53ec7cecd88eff35329cba8e61 (patch)
tree0c252d950c28e02f192c36219495d2ec5fa429f1
parentef814218cab0e47109d9cd691fbe33794513d293 (diff)
downloadaur-2577aa7fd0f86e53ec7cecd88eff35329cba8e61.tar.gz
Update to 0.6.0
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD19
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e09edb743776..793e7b83799c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pandoc-include
pkgdesc = Panflute filter to allow file includes
- pkgver = 0.3.2
+ pkgver = 0.6.0
pkgrel = 1
url = https://github.com/DCsunset/pandoc-include
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 6f73a34e2794..9a1c0a3c378b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,25 +4,22 @@
_pipname=pandoc-include
pkgname=python-$_pipname
-pkgver=0.3.2
+pkgver=0.6.0
pkgrel=1
pkgdesc="Panflute filter to allow file includes"
arch=(any)
url="https://github.com/DCsunset/$_pipname"
license=(MIT)
-makedepends=("python" "python-pip")
-depends=("python-click"
- "python-future"
- "python-panflute"
- "python-shutilwhich"
- "python-yaml")
+makedepends=('python' 'python-pip')
+_py_deps=('click' 'future' 'panflute' 'shutilwhich' 'yaml')
+depends=("${_py_deps[@]/#/python-}")
build() {
- pip install --no-deps --target="$_pipname" "$_pipname==$pkgver"
+ pip install --no-deps --target="$_pipname" "$_pipname==$pkgver"
}
package() {
- sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
- mkdir -p "$pkgdir/$sitepackages"
- cp -r "$srcdir/$_pipname"/* "$pkgdir/$sitepackages"
+ sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
+ mkdir -p "$pkgdir/$sitepackages"
+ cp -r "$srcdir/$_pipname"/* "$pkgdir/$sitepackages"
}