summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2019-03-01 14:40:00 +0000
committerCaleb Maclennan2019-03-01 14:40:00 +0000
commit10616fec16481adb3428920d9669a7a5df0d4548 (patch)
treee8c6f3963e0b3fe065fb36957964c4ee10cfdb2d
downloadaur-10616fec16481adb3428920d9669a7a5df0d4548.tar.gz
Init: pipman panflute
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9865db80687a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python-panflute
+ pkgdesc = Pythonic Pandoc filters
+ pkgver = 1.11.2
+ pkgrel = 1
+ url = https://github.com/sergiocorreia/panflute
+ arch = any
+ license = BSD3
+ makedepends = python
+ makedepends = python-pip
+
+pkgname = python-panflute
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98149606f2e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# PKGBUILD generated by pipman
+# Python package author: Sergio Correia <sergio.correia@gmail.com>
+pkgname=python-panflute
+pkgver=1.11.2
+pkgrel=1
+pkgdesc="Pythonic Pandoc filters"
+arch=(any)
+url="https://github.com/sergiocorreia/panflute"
+license=(BSD3)
+makedepends=("python" "python-pip")
+build() {
+ pip install --no-deps --target="panflute" panflute==1.11.2
+}
+package() {
+ sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
+ mkdir -p $pkgdir/"$sitepackages"
+ cp -r $srcdir/panflute/* $pkgdir/"$sitepackages"
+} \ No newline at end of file