summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2022-07-14 12:36:09 +0300
committerCaleb Maclennan2022-07-14 12:36:09 +0300
commit22225d111f0a50b17c17d9eefa305bcc86fe168a (patch)
tree19ba5c3e6dfa3b7f94a5a42e7d5ccae592cb05d6
parentb405e53d1c76810dd3f2eb5f42936a0f5ddb31f5 (diff)
downloadaur-22225d111f0a50b17c17d9eefa305bcc86fe168a.tar.gz
upgpkg: python-panflute 2.2.1-1
upstream release
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd207b9b216d..a82be4349b35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-panflute
pkgdesc = A Pythonic alternative to John MacFarlane’s pandocfilters
- pkgver = 2.1.3
- pkgrel = 2
+ pkgver = 2.2.1
+ pkgrel = 1
url = https://github.com/sergiocorreia/panflute
arch = any
license = BSD
@@ -10,16 +10,16 @@ pkgbase = python-panflute
checkdepends = python-pytest-cov
makedepends = python-build
makedepends = python-installer
- makedepends = python-setuptools
makedepends = python-wheel
+ makedepends = python-setuptools
depends = pandoc
depends = python
depends = python-click
depends = python-yaml
- provides = pandoc-panflute=2.1.3
+ provides = pandoc-panflute=2.2.1
conflicts = pandoc-panflute
replaces = pandoc-panflute
- source = https://github.com/sergiocorreia/panflute/archive/2.1.3/panflute-2.1.3.tar.gz
- sha256sums = 8e49cc658cdcdbfa66aab8a9e48a414d42b924d2aa2cc225d0215f8f9955568f
+ source = https://github.com/sergiocorreia/panflute/archive/v2.2.1/panflute-2.2.1.tar.gz
+ sha256sums = 6dff90cb986ba1cc29830e0782d3e3f0a5e9add73c6bcfa9c2d5368b2a8921e0
pkgname = python-panflute
diff --git a/PKGBUILD b/PKGBUILD
index 266dc2a7065f..8b5c2a041899 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pyname=panflute
pkgname=python-$_pyname
-pkgver=2.1.3
-pkgrel=2
+pkgver=2.2.1
+pkgrel=1
pkgdesc='A Pythonic alternative to John MacFarlane’s pandocfilters'
arch=(any)
url="https://github.com/sergiocorreia/$_pyname"
@@ -14,9 +14,8 @@ _pydeps=(click
depends=(pandoc
python
"${_pydeps[@]/#/python-}")
-makedepends=(python-{build,installer}
- python-setuptools
- python-wheel)
+makedepends=(python-{build,installer,wheel}
+ python-setuptools)
_pycheckdeps=(pandocfilters
pytest
pytest-cov)
@@ -25,8 +24,8 @@ provides=("pandoc-$_pyname=$pkgver")
conflicts=("pandoc-$_pyname")
replaces=("pandoc-$_pyname")
_archive="$_pyname-$pkgver"
-source=("$url/archive/$pkgver/$_archive.tar.gz")
-sha256sums=('8e49cc658cdcdbfa66aab8a9e48a414d42b924d2aa2cc225d0215f8f9955568f')
+source=("$url/archive/v$pkgver/$_archive.tar.gz")
+sha256sums=('6dff90cb986ba1cc29830e0782d3e3f0a5e9add73c6bcfa9c2d5368b2a8921e0')
build() {
cd "$_archive"