summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-10-03 19:56:55 +0300
committerCaleb Maclennan2020-10-03 20:09:31 +0300
commit2973a1dc0cc3c7ce30bf4eeba4449204193815dd (patch)
tree3acb4e7721388dad3167bb51367a8a2d8977a578
parent6926a5ab159628d5ada8e62d83956db4cc48f3b1 (diff)
downloadaur-2973a1dc0cc3c7ce30bf4eeba4449204193815dd.tar.gz
upgpkg: python-panflute 1.12.5-7
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
-rw-r--r--python-panflute.install14
3 files changed, 20 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1db50fe2f09..9d7f99312d3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = python-panflute
pkgdesc = A Pythonic alternative to John MacFarlane’s pandocfilters
pkgver = 1.12.5
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/sergiocorreia/panflute
+ install = python-panflute.install
arch = any
license = BSD
checkdepends = python-pandocfilters
checkdepends = python-pytest-cov
makedepends = python-setuptools
- depends = pandoc<2.10.0
+ depends = pandoc
depends = python
depends = python-click
depends = python-yaml
diff --git a/PKGBUILD b/PKGBUILD
index 986c7cf22221..859ee9f961d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,20 @@
_pipname=panflute
pkgname=python-$_pipname
pkgver=1.12.5
-pkgrel=6
+pkgrel=7
pkgdesc='A Pythonic alternative to John MacFarlane’s pandocfilters'
url="https://github.com/sergiocorreia/$_pipname"
arch=('any')
license=('BSD')
_pydeps=('click'
'yaml')
-depends=('pandoc<2.10.0' 'python' "${_pydeps[@]/#/python-}")
+depends=('pandoc' 'python' "${_pydeps[@]/#/python-}")
makedepends=('python-setuptools')
replaces=('pandoc-panflute')
_pycheckdeps=('pandocfilters'
'pytest-cov')
checkdepends=("${_pycheckdeps[@]/#/python-}")
+install=$pkgname.install
source=("$pkgname-$pkgver.tar.gz::https://github.com/sergiocorreia/$_pipname/archive/$pkgver.tar.gz")
sha256sums=('ee62188825f7623eb348e15d2183c6ee51e28cf3f0c87c851e6f09ad7288f78d')
diff --git a/python-panflute.install b/python-panflute.install
new file mode 100644
index 000000000000..0990db7381e8
--- /dev/null
+++ b/python-panflute.install
@@ -0,0 +1,14 @@
+post_install() {
+ cat <<- EOF 1>&2
+ --> WARNING: Panflute is not 100% compatible with Pandoc 2.10+. Most
+ --> notibly anything to do with tables is not supported, see upstream
+ --> issue here: https://github.com/sergiocorreia/panflute/issues/142
+ --> In order to use, please downgrade Pandoc to 2.9.x (one way is to
+ --> use a pacman mirror that has an archive of old packages, then add
+ --> Pandoc to your HoldPkg list).
+ EOF
+}
+
+post_upgrade() {
+ post_install
+}