summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-06-12 12:09:25 +0300
committerCaleb Maclennan2021-06-12 12:09:25 +0300
commit6a293a2e5dfeaf844358dd088ee51327802bac6a (patch)
treed156db750915ce304a1caefdde36ca3268aa2c30
parentd4c568bec09fcb33a4a1cf050348ff3f2017cdcc (diff)
downloadaur-6a293a2e5dfeaf844358dd088ee51327802bac6a.tar.gz
upgpkg: python-panflute 2.1.1-2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD43
-rw-r--r--python-panflute.install14
3 files changed, 25 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0d090058c5b..cf737dd2f4d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = python-panflute
pkgdesc = A Pythonic alternative to John MacFarlane’s pandocfilters
pkgver = 2.1.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/sergiocorreia/panflute
- install = python-panflute.install
arch = any
license = BSD
checkdepends = python-pandocfilters
@@ -14,8 +13,7 @@ pkgbase = python-panflute
depends = python-click
depends = python-yaml
replaces = pandoc-panflute
- source = python-panflute-2.1.1.tar.gz::https://github.com/sergiocorreia/panflute/archive/2.1.1.tar.gz
+ source = panflute-2.1.1.tar.gz::https://github.com/sergiocorreia/panflute/archive/2.1.1.tar.gz
sha256sums = e8c4580f36277ae195dc1614e7cff239d5d3eb0c40ef7e1abb676f6aa2df127c
pkgname = python-panflute
-
diff --git a/PKGBUILD b/PKGBUILD
index de2f71b1ca2e..4a7f1f7db164 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,40 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
# Mantainer: Michael M. Tung <mtung at mat dot upv dot es>
-_pipname=panflute
-pkgname=python-$_pipname
+_py_name=panflute
+pkgname=python-$_py_name
pkgver=2.1.1
-pkgrel=1
+pkgrel=2
pkgdesc='A Pythonic alternative to John MacFarlane’s pandocfilters'
-url="https://github.com/sergiocorreia/$_pipname"
-arch=('any')
-license=('BSD')
-_pydeps=('click'
- 'yaml')
-depends=('pandoc>=2.11.0.4' 'python' "${_pydeps[@]/#/python-}")
-makedepends=('python-setuptools')
-replaces=('pandoc-panflute')
-_pycheckdeps=('pandocfilters'
- 'pytest-cov')
-checkdepends=("${_pycheckdeps[@]/#/python-}")
-install=$pkgname.install
-source=("$pkgname-$pkgver.tar.gz::https://github.com/sergiocorreia/$_pipname/archive/$pkgver.tar.gz")
+url="https://github.com/sergiocorreia/$_py_name"
+arch=(any)
+license=(BSD)
+_pydeps=(click yaml)
+depends=('pandoc>=2.11.0.4' python "${_pydeps[@]/#/python-}")
+makedepends=(python-setuptools)
+replaces=(pandoc-panflute)
+_py_checkdeps=(pandocfilters pytest-cov)
+checkdepends=("${_py_checkdeps[@]/#/python-}")
+_archive="$_py_name-$pkgver"
+source=("$_archive.tar.gz::$url/archive/$pkgver.tar.gz")
sha256sums=('e8c4580f36277ae195dc1614e7cff239d5d3eb0c40ef7e1abb676f6aa2df127c')
+prepare() {
+ cd "$_archive"
+ sed -i -e '/click/s/<8/<9/' setup.py
+}
+
build() {
- cd "$_pipname-$pkgver"
+ cd "$_archive"
python setup.py build
}
check() {
- cd "$_pipname-$pkgver"
+ cd "$_archive"
python setup.py test
}
package() {
- cd "$_pipname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd "$_archive"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}
diff --git a/python-panflute.install b/python-panflute.install
deleted file mode 100644
index 0990db7381e8..000000000000
--- a/python-panflute.install
+++ /dev/null
@@ -1,14 +0,0 @@
-post_install() {
- cat <<- EOF 1>&2
- --> WARNING: Panflute is not 100% compatible with Pandoc 2.10+. Most
- --> notibly anything to do with tables is not supported, see upstream
- --> issue here: https://github.com/sergiocorreia/panflute/issues/142
- --> In order to use, please downgrade Pandoc to 2.9.x (one way is to
- --> use a pacman mirror that has an archive of old packages, then add
- --> Pandoc to your HoldPkg list).
- EOF
-}
-
-post_upgrade() {
- post_install
-}