summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2019-12-02 12:00:27 +0300
committerCaleb Maclennan2019-12-02 12:09:46 +0300
commiteefd7b1725b909d38228b3fe7b062bf733e65f2b (patch)
treeada695c53a6a4dd7eb79d3160c761419c9287cac
parent328a83f63028919414a07a9dd22ee78d1177845d (diff)
downloadaur-eefd7b1725b909d38228b3fe7b062bf733e65f2b.tar.gz
Include symlinks to python binaries
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f16a79c56340..2a07e7605cf4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pantable
pkgdesc = CSV Tables in Markdown: Pandoc Filter for CSV Tables
pkgver = 0.12.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ickc/pantable
arch = any
license = GPLv3
diff --git a/PKGBUILD b/PKGBUILD
index 3c52dc7f4f93..07ecf4679c59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pipname=pantable
pkgname=python-$_pipname
pkgver=0.12.2
-pkgrel=1
+pkgrel=2
pkgdesc="CSV Tables in Markdown: Pandoc Filter for CSV Tables"
arch=(any)
url="https://github.com/ickc/$_pipname"
@@ -26,4 +26,7 @@ package() {
sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
mkdir -p "$pkgdir/$sitepackages"
cp -r "$srcdir/$_pipname"/* "$pkgdir/$sitepackages"
+ install -d "$pkgdir/usr/bin"
+ ln -s {$(python -c "import site; print(site.getsitepackages()[0]+'/bin')"),$pkgdir/usr/bin}/pantable
+ ln -s {$(python -c "import site; print(site.getsitepackages()[0]+'/bin')"),$pkgdir/usr/bin}/pantable2csv
}