summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-12-19 10:15:31 +0300
committerCaleb Maclennan2020-12-19 10:24:10 +0300
commit87f9030c1db76d2e08fd78b9a3455d40300a227e (patch)
tree0f4b88dec0e074cc213fa94c859e657bc8efaf44
parent22272dac0ce29146139ea9ada31dd2479a0986ae (diff)
downloadaur-87f9030c1db76d2e08fd78b9a3455d40300a227e.tar.gz
upgpkg: python-pantable-git 0.13.1.r4.g76034d9-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 14 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca957930db7f..fec2921a995a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = python-pantable-git
pkgdesc = CSV Tables in Markdown: Pandoc Filter for CSV Tables
- pkgver = 0.12.4.r9.g964b436
+ pkgver = 0.13.1.r4.g76034d9
pkgrel = 1
url = https://github.com/ickc/pantable
arch = any
license = GPL3
- makedepends = python-setuptools
- depends = pandoc
+ makedepends = python-pip
+ depends = pandoc>=2.11.2
depends = python
depends = python-panflute>=2
depends = python-yaml
- provides = python-pantable
+ provides = python-pantable=0.13.1.r4.g76034d9
conflicts = python-pantable
source = python-pantable-git::git+https://github.com/ickc/pantable.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d30b2fc21faa..25c612d7a31b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,30 @@
_name=pantable
pkgname=python-$_name-git
-pkgver=0.12.4.r9.g964b436
+pkgver=0.13.1.r4.g76034d9
pkgrel=1
pkgdesc='CSV Tables in Markdown: Pandoc Filter for CSV Tables'
arch=('any')
url="https://github.com/ickc/$_name"
license=('GPL3')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
_py_deps=('panflute>=2'
'yaml')
-depends=('pandoc' 'python' "${_py_deps[@]/#/python-}")
-makedepends=('python-setuptools')
+depends=('pandoc>=2.11.2'
+ 'python'
+ "${_py_deps[@]/#/python-}")
+makedepends=('python-pip')
+provides=("${pkgname%-git}=$pkgver")
+conflicts=("${pkgname%-git}")
source=("$pkgname::git+$url.git")
sha256sums=('SKIP')
pkgver() {
cd "${pkgname}"
- git describe --tags --abbrev=7 HEAD | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-build() {
- cd "${pkgname}"
- python setup.py build
+ git describe --long --always --tags --abbrev=7 HEAD |
+ sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
cd "${pkgname}"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ pip install --isolated --root="$pkgdir" --ignore-installed --no-deps .
}