summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP-Ellis2018-08-13 19:37:21 +0200
committerJP-Ellis2018-08-13 19:37:21 +0200
commit06b3e8455d7467488d50c21d5f88c4eb9d1004f4 (patch)
treef4139d2cabdc3b32ae34608a93328f941172170b
downloadaur-06b3e8455d7467488d50c21d5f88c4eb9d1004f4.tar.gz
Initial commit
Signed-off-by: JP-Ellis <josh@jpellis.me>
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD26
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..da7c53e1bd4e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Mon Aug 13 17:37:07 UTC 2018
+pkgbase = python-papis-python-rofi
+ pkgdesc = Create simple GUIs using the Rofi application (fork for papis)
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://pypi.org/project/papis-python-rofi/
+ arch = any
+ license = GPL
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/p/papis-python-rofi/papis-python-rofi-1.0.2.tar.gz
+ sha256sums = 3bd01a9db97b620c4249e89e37c2fe669ba405ac179ea3bffa43246c05af668e
+
+pkgname = python-papis-python-rofi
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..335ec9573de5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ee985f415ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: JP-Ellis <josh@jpellis.me>
+pkgname=python-papis-python-rofi
+_name=${pkgname#python-}
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Create simple GUIs using the Rofi application (fork for papis)"
+arch=('any')
+url="https://pypi.org/project/papis-python-rofi/"
+license=('GPL')
+depends=('python')
+optdepends=()
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('3bd01a9db97b620c4249e89e37c2fe669ba405ac179ea3bffa43246c05af668e')
+noextract=()
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+
+# vim:set ts=2 sw=2 et: