summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Stone2020-11-25 23:41:07 -0700
committerEli Stone2020-11-25 23:41:07 -0700
commit86c4ec29524915b050ee86b1e6d095153d0deb9b (patch)
treeb3b8431aa94e7eddde6b68bf57a6d48bb2a23119
downloadaur-86c4ec29524915b050ee86b1e6d095153d0deb9b.tar.gz
python-parallelencode v0.1.4 is a new framework for parallel encoding similar to av1an but designed to be modular and easily usable by many frontends/tools.
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD38
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..997ea048f5a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = python-parallelencode
+ pkgdesc = A python framework to split and encode videos in parallel
+ pkgver = 0.1.4
+ pkgrel = 1
+ url = https://github.com/parallelencode/PyParallelEncode
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python
+ depends = python-psutil
+ depends = python-scipy
+ depends = python-numpy
+ depends = ffmpeg
+ optdepends = python-scenedetect
+ optdepends = vmaf
+ optdepends = vapoursynth-plugin-lsmashsource
+ optdepends = libvpx
+ optdepends = aom
+ optdepends = x264
+ optdepends = x265
+ source = https://files.pythonhosted.org/packages/source/p/parallelencode/parallelencode-0.1.4.tar.gz
+ sha256sums = c4e3c7dddebeabd3752659ee3e4dd503040b7c5dfcb842146de55cd494caf508
+
+pkgname = python-parallelencode
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..773ab0f2dddb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Eli Stone <eli.stonium@gmail.com>
+
+pkgname=python-parallelencode
+_name="${pkgname#python-}"
+pkgver=0.1.4
+pkgrel=1
+pkgdesc='A python framework to split and encode videos in parallel'
+url='https://github.com/parallelencode/PyParallelEncode'
+arch=('any')
+license=('GPL3')
+source=(
+ "https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
+)
+makedepends=('python-setuptools')
+depends=(
+ 'python' 'python-scipy' 'python-psutil'
+ 'ffmpeg' 'python-numpy'
+)
+optdepends=('vmaf: Target vmaf support',
+'python-scenedetect: Splitting based on scenedetect instead of (the faster and better) ffmpeg',
+'vapoursynth-plugin-lsmashsource: Do not create split files, use vapoursynth to split instead',
+'libvpx: vp8/vp9 output support',
+'aom: av1 output support',
+'x264: h264/AVC output support',
+'x265: h265/HEVC output support',
+)
+
+sha256sums=('c4e3c7dddebeabd3752659ee3e4dd503040b7c5dfcb842146de55cd494caf508')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}