summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2019-03-21 17:19:15 +0100
committerMichel Zou2019-03-21 17:19:15 +0100
commit1b39086b19b70c70c79dafe425731734d3950d9e (patch)
tree9d82cdd0d368e87f28ab1e4cf2faa14f52efa422
parent52c37c59034af1ba3f325bb86d08333d23373711 (diff)
downloadaur-1b39086b19b70c70c79dafe425731734d3950d9e.tar.gz
0.2.3
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD30
2 files changed, 10 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d8f0f61b040..e48e6a1b2246 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,16 @@
-# Generated by mksrcinfo v8
-# Fri Aug 4 19:19:43 UTC 2017
pkgbase = python-pathos
pkgdesc = parallel graph management and execution in heterogeneous computing
- pkgver = 0.2.1
+ pkgver = 0.2.3
pkgrel = 1
url = http://trac.mystic.cacr.caltech.edu/project/pathos/wiki.html
arch = any
license = BSD
makedepends = python-setuptools
- makedepends = python2-setuptools
- makedepends = python-ppft
- makedepends = python2-ppft
- makedepends = python-pox
- makedepends = python2-pox
- makedepends = python-multiprocess
- makedepends = python2-multiprocess
- source = https://github.com/uqfoundation/pathos/archive/pathos-0.2.1.tar.gz
- sha1sums = e00d5ac3712a2ec02f54749815117dc1afab82e6
-
-pkgname = python-pathos
depends = python-ppft
depends = python-pox
depends = python-multiprocess
+ source = https://github.com/uqfoundation/pathos/archive/pathos-0.2.3.tar.gz
+ sha256sums = 5a325a19f66bd92fe3978febf4e96b8836f45f851ab23b07eaf589beac9c21bc
-pkgname = python2-pathos
- depends = python2-ppft
- depends = python2-pox
- depends = python2-multiprocess
+pkgname = python-pathos
diff --git a/PKGBUILD b/PKGBUILD
index 0e9c22be661b..c36fa4866fd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,23 @@
-pkgbase=python-pathos
-pkgname=('python-pathos' 'python2-pathos')
-pkgver=0.2.1
+pkgname=python-pathos
+pkgver=0.2.3
pkgrel=1
pkgdesc="parallel graph management and execution in heterogeneous computing"
url="http://trac.mystic.cacr.caltech.edu/project/pathos/wiki.html"
arch=(any)
license=('BSD')
-makedepends=('python-setuptools' 'python2-setuptools' 'python-ppft' 'python2-ppft' 'python-pox' 'python2-pox' 'python-multiprocess' 'python2-multiprocess')
+makedepends=('python-setuptools')
+depends=('python-ppft' 'python-pox' 'python-multiprocess')
source=("https://github.com/uqfoundation/pathos/archive/pathos-${pkgver}.tar.gz")
-sha1sums=('e00d5ac3712a2ec02f54749815117dc1afab82e6')
+sha256sums=('5a325a19f66bd92fe3978febf4e96b8836f45f851ab23b07eaf589beac9c21bc')
build() {
- cp -r "${srcdir}"/pathos-pathos-$pkgver "${srcdir}"/pathos-$pkgver
- cp -r "${srcdir}"/pathos-$pkgver "${srcdir}"/pathos-$pkgver-py2
-
cd "${srcdir}"/pathos-$pkgver
python setup.py build
-
- cd "${srcdir}"/pathos-$pkgver-py2
- python2 setup.py build
}
-package_python-pathos() {
- depends=('python-ppft' 'python-pox' 'python-multiprocess')
-
+package() {
cd "${srcdir}/pathos-$pkgver"
python setup.py install --root=${pkgdir} --optimize=1
}
-package_python2-pathos() {
- depends=('python2-ppft' 'python2-pox' 'python2-multiprocess')
-
- cd "${srcdir}/pathos-$pkgver"
- python2 setup.py install --root=${pkgdir} --optimize=1
- mv ${pkgdir}/usr/bin/pathos_server.py ${pkgdir}/usr/bin/pathos_server2.py
- mv ${pkgdir}/usr/bin/pathos_tunnel.py ${pkgdir}/usr/bin/pathos_tunnel2.py
- mv ${pkgdir}/usr/bin/portpicker.py ${pkgdir}/usr/bin/portpicker2.py
- mv ${pkgdir}/usr/bin/tunneled_pathos_server.py ${pkgdir}/usr/bin/tunneled_pathos_server2.py
-}