summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2021-09-20 10:59:11 -0500
committerCarlos Aznarán Laos2021-09-20 10:59:11 -0500
commitdb46eb1f44f18ec52e3c13603d17cf256a3032f5 (patch)
treee6e286ab11ed7a8e440bd6a566b7ddb197c4ce28
parentf776f3b11ad0d1936e72b8905536a8427c8bbb77 (diff)
downloadaur-db46eb1f44f18ec52e3c13603d17cf256a3032f5.tar.gz
Version bump to 0.2.8
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD33
3 files changed, 24 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e48e6a1b2246..64fa78c591b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = python-pathos
pkgdesc = parallel graph management and execution in heterogeneous computing
- pkgver = 0.2.3
+ pkgver = 0.2.8
pkgrel = 1
- url = http://trac.mystic.cacr.caltech.edu/project/pathos/wiki.html
+ url = https://github.com/uqfoundation/pathos
arch = any
license = BSD
makedepends = python-setuptools
depends = python-ppft
depends = python-pox
depends = python-multiprocess
- source = https://github.com/uqfoundation/pathos/archive/pathos-0.2.3.tar.gz
- sha256sums = 5a325a19f66bd92fe3978febf4e96b8836f45f851ab23b07eaf589beac9c21bc
+ source = https://github.com/uqfoundation/pathos/archive/pathos-0.2.8.tar.gz
+ sha512sums = 3552e7db41ec134fdebcda0e8e483e1f06e8de18b1e31184599d44c35367baf02f04d8c4f8932820e1793eeb81c4fddab6eb2026fae0ebd932be50d708f2e214
pkgname = python-pathos
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index c9e3114505fd..5d3b21614f27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,28 @@
-pkgname=python-pathos
-pkgver=0.2.3
-pkgrel=1
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Michel Zou <xantares09@hotmail.com>
+_base=pathos
+pkgname=python-${_base}
pkgdesc="parallel graph management and execution in heterogeneous computing"
-url="http://trac.mystic.cacr.caltech.edu/project/pathos/wiki.html"
-arch=(any)
+pkgver=0.2.8
+pkgrel=1
+url="https://github.com/uqfoundation/${_base}"
+arch=('any')
license=('BSD')
-makedepends=('python-setuptools')
-depends=('python-ppft' 'python-pox' 'python-multiprocess')
-source=("https://github.com/uqfoundation/pathos/archive/pathos-${pkgver}.tar.gz")
-sha256sums=('5a325a19f66bd92fe3978febf4e96b8836f45f851ab23b07eaf589beac9c21bc')
+depends=(python-ppft python-pox python-multiprocess)
+makedepends=(python-setuptools)
+source=(${url}/archive/${_base}-${pkgver}.tar.gz)
+sha512sums=('3552e7db41ec134fdebcda0e8e483e1f06e8de18b1e31184599d44c35367baf02f04d8c4f8932820e1793eeb81c4fddab6eb2026fae0ebd932be50d708f2e214')
+
+export PYTHONPYCACHEPREFIX="${BUILDDIR}/${pkgname}/.cache/cpython/"
build() {
- cd "${srcdir}"/pathos-pathos-$pkgver
+ cd "${_base}-${_base}-${pkgver}"
python setup.py build
}
package() {
- cd "${srcdir}/pathos-pathos-$pkgver"
- python setup.py install --root=${pkgdir} --optimize=1
+ cd "${_base}-${_base}-${pkgver}"
+ export PYTHONHASHSEED=0
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
-
-