summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Margiani2019-02-25 16:28:05 +0100
committerGabriel Margiani2019-02-25 16:28:05 +0100
commit9232874a254cb058f614196ca4a92329e604eaf6 (patch)
tree6bf17db4df6febaae367cdda53092a3889b7ec2d
downloadaur-9232874a254cb058f614196ca4a92329e604eaf6.tar.gz
Add package
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0b2bdab95f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-pathpy-git
+ pkgdesc = Analysis of time series data on networks with higher- and multi-order graphical models
+ pkgver = r432.fa06dc5
+ pkgrel = 1
+ url = http://www.pathpy.net
+ arch = i686
+ arch = x86_64
+ license = AGPL
+ makedepends = python-setuptools
+ depends = python
+ depends = python-numpy
+ depends = python-scipy
+ provides = python-pathpy
+ conflicts = python-pathpy
+ source = python-pathpy-git::git+https://github.com/uzhdag/pathpy.git
+ md5sums = SKIP
+
+pkgname = python-pathpy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b04b2398379
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+#Maintainer: Gabriel Margiani <gabriel _strange_curved_character_ margiani · ch>
+pkgname='python-pathpy-git'
+pkgver=r432.fa06dc5
+pkgrel=1
+pkgdesc="Analysis of time series data on networks with higher- and multi-order graphical models"
+arch=('i686' 'x86_64')
+url="http://www.pathpy.net"
+license=('AGPL')
+provides=('python-pathpy')
+conflicts=('python-pathpy')
+depends=('python' 'python-numpy' 'python-scipy')
+makedepends=('python-setuptools')
+source=("$pkgname::git+https://github.com/uzhdag/pathpy.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $pkgname
+ python setup.py build
+}
+package() {
+ cd $pkgname
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+