summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfordprefect2021-01-25 13:37:05 +0100
committerfordprefect2021-01-25 13:37:05 +0100
commit1ee01207d988e26917291eade7922fd54b03183b (patch)
treed6101157029d52d9c5fab837ff39f2fcdcbbeb56
parentffb9e2258480fa4cabdbdeb5c6f1b33467c9920d (diff)
downloadaur-1ee01207d988e26917291eade7922fd54b03183b.tar.gz
2.3.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 8 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4380f35fed79..34886e719e8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-pathvalidate
pkgdesc = Sanitize/validate strings in filenames/file-paths/etc
- pkgver = 2.3.1
+ pkgver = 2.3.2
pkgrel = 1
url = https://github.com/thombashi/pathvalidate
arch = any
license = MIT
makedepends = python-setuptools
depends = python
- source = https://files.pythonhosted.org/packages/source/p/pathvalidate/pathvalidate-2.3.1.tar.gz
- sha256sums = 1be91f23dd1fb5002ad2b52cb4e7396deb56092ef29a7facb6e4032c5a444f8a
+ source = https://github.com/thombashi/pathvalidate/archive/v2.3.2.tar.gz
+ sha256sums = ff9d3f5ae2ab29124545324da51bcc4788a6fe52b9ddc3b74b1707920e2b099a
pkgname = python-pathvalidate
diff --git a/PKGBUILD b/PKGBUILD
index 7c7aba81ffcf..b3bd11ade16e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,17 @@
-# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
-# Contributor: vanyasem
-# Contributor: Florian Wittmann
+# Contributors: Caltlgin Stsodaat, vanyasem, Florian Wittmann
_pkgname='pathvalidate'
-pkgname="python-${_pkgname}"
-pkgver=2.3.1
+pkgname=python-$_pkgname
+pkgver=2.3.2
pkgrel=1
pkgdesc='Sanitize/validate strings in filenames/file-paths/etc'
arch=('any')
url='https://github.com/thombashi/pathvalidate'
-_url_pypi='https://pypi.org/project/pathvalidate'
license=('MIT')
depends=('python')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('1be91f23dd1fb5002ad2b52cb4e7396deb56092ef29a7facb6e4032c5a444f8a')
+source=("https://github.com/thombashi/pathvalidate/archive/v$pkgver.tar.gz")
+sha256sums=('ff9d3f5ae2ab29124545324da51bcc4788a6fe52b9ddc3b74b1707920e2b099a')
build() {
cd "${_pkgname}-${pkgver}"
@@ -27,5 +24,3 @@ package() {
install -Dvm644 'README.rst' -t "${pkgdir}/usr/share/doc/${pkgname}"
install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
-
-# vim: ts=2 sw=2 et: