summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew DeVault2017-12-09 10:06:47 -0500
committerDrew DeVault2017-12-09 10:11:24 -0500
commitbf144357304fe64e57bf4d79a4e98fce9f28caf3 (patch)
tree7d35b07bba5eb952c4215786dee8edf4daea1220
downloadaur-bf144357304fe64e57bf4d79a4e98fce9f28caf3.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f5649af7646
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat Dec 9 15:11:18 UTC 2017
+pkgbase = python-patreon
+ pkgdesc = Python wrapper for the Patreon API
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = http://github.com/Patreon/patreon-python
+ arch = any
+ license = MIT
+ makedepends = python-distribute
+ depends = python-requests
+ source = https://files.pythonhosted.org/packages/source/p/patreon/patreon-0.4.0.tar.gz
+ sha256sums = aeaf57baebdf7eb7abc73f061192871245e74b295aa08ca491c01bca7f7aefa6
+
+pkgname = python-patreon
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0a2223f3641d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..429fc12cd281
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+_name=patreon
+pkgname="python-patreon"
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="Python wrapper for the Patreon API"
+arch=("any")
+url="http://github.com/Patreon/patreon-python"
+license=("MIT")
+depends=("python-requests")
+makedepends=("python-distribute")
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('aeaf57baebdf7eb7abc73f061192871245e74b295aa08ca491c01bca7f7aefa6')
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python ./setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}