summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Asuncion2016-11-11 04:16:50 -0800
committerJeremy Asuncion2016-11-11 04:16:50 -0800
commit042729729facb141b096d2e55834347cbb357648 (patch)
tree16de36fdb8611c8d92e6a68ab87709f4c9b04d5a
parent961fa410a4f6feac61ed0bf5d875e324abf0f43c (diff)
downloadaur-042729729facb141b096d2e55834347cbb357648.tar.gz
Added build() hook for python-pawk, added license to PKGBUILD
-rwxr-xr-xLICENSE41
-rw-r--r--PKGBUILD8
2 files changed, 48 insertions, 1 deletions
diff --git a/LICENSE b/LICENSE
new file mode 100755
index 000000000000..9b8a91831c3b
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,41 @@
+1. This LICENSE AGREEMENT is between the Python Software Foundation ("PSF"), and
+ the Individual or Organization ("Licensee") accessing and otherwise using Python
+ 3.5.2 software in source or binary form and its associated documentation.
+
+2. Subject to the terms and conditions of this License Agreement, PSF hereby
+ grants Licensee a nonexclusive, royalty-free, world-wide license to reproduce,
+ analyze, test, perform and/or display publicly, prepare derivative works,
+ distribute, and otherwise use Python 3.5.2 alone or in any derivative
+ version, provided, however, that PSF's License Agreement and PSF's notice of
+ copyright, i.e., "Copyright © 2001-2016 Python Software Foundation; All Rights
+ Reserved" are retained in Python 3.5.2 alone or in any derivative version
+ prepared by Licensee.
+
+3. In the event Licensee prepares a derivative work that is based on or
+ incorporates Python 3.5.2 or any part thereof, and wants to make the
+ derivative work available to others as provided herein, then Licensee hereby
+ agrees to include in any such work a brief summary of the changes made to Python
+ 3.5.2.
+
+4. PSF is making Python 3.5.2 available to Licensee on an "AS IS" basis.
+ PSF MAKES NO REPRESENTATIONS OR WARRANTIES, EXPRESS OR IMPLIED. BY WAY OF
+ EXAMPLE, BUT NOT LIMITATION, PSF MAKES NO AND DISCLAIMS ANY REPRESENTATION OR
+ WARRANTY OF MERCHANTABILITY OR FITNESS FOR ANY PARTICULAR PURPOSE OR THAT THE
+ USE OF PYTHON 3.5.2 WILL NOT INFRINGE ANY THIRD PARTY RIGHTS.
+
+5. PSF SHALL NOT BE LIABLE TO LICENSEE OR ANY OTHER USERS OF PYTHON 3.5.2
+ FOR ANY INCIDENTAL, SPECIAL, OR CONSEQUENTIAL DAMAGES OR LOSS AS A RESULT OF
+ MODIFYING, DISTRIBUTING, OR OTHERWISE USING PYTHON 3.5.2, OR ANY DERIVATIVE
+ THEREOF, EVEN IF ADVISED OF THE POSSIBILITY THEREOF.
+
+6. This License Agreement will automatically terminate upon a material breach of
+ its terms and conditions.
+
+7. Nothing in this License Agreement shall be deemed to create any relationship
+ of agency, partnership, or joint venture between PSF and Licensee. This License
+ Agreement does not grant permission to use PSF trademarks or trade name in a
+ trademark sense to endorse or promote products or services of Licensee, or any
+ third party.
+
+8. By copying, installing or otherwise using Python 3.5.2, Licensee agrees
+ to be bound by the terms and conditions of this License Agreement.
diff --git a/PKGBUILD b/PKGBUILD
index 1312e77e0609..4f548c36453e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,8 +14,14 @@ makedepends=('python-setuptools')
source=("https://pypi.python.org/packages/ab/5a/c22c6ff37c74196950fad281b1094547e06065d5c922d8b679458e5f37b5/${_name}-${pkgver}.tar.gz")
md5sums=('d5fa14a9a18db14d426f040872b06b45')
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py build
+}
+
package() {
+ install -Dm644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
cd "${srcdir}/${_name}-${pkgver}"
- python setup.py install --prefix=/usr --root="${pkgdir}"
+ python setup.py install -O1 --skip-build --prefix=/usr --root="${pkgdir}"
}