summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-08-25 21:23:00 +0300
committerViktor Drobot2020-08-25 21:23:00 +0300
commit6324f0d79939fbb7f148786e47bd8650da2e1e29 (patch)
tree429020991f4bef043052f3f9bd937ea70d4818c7
parent72aab27733dbfc9963e7d94a125d0152ee2ff074 (diff)
downloadaur-6324f0d79939fbb7f148786e47bd8650da2e1e29.tar.gz
Fix issue with matched atoms
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--fix_matchedatoms.patch34
3 files changed, 43 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14fb38fce1ea..ea068f952069 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pdb2pqr
pkgdesc = Automates many of the common tasks of preparing structures for continuum solvation calculations as well as many other types of biomolecular structure modeling, analysis, and simulation.
pkgver = 3.0.1
- pkgrel = 2
+ pkgrel = 3
url = http://pypi.python.org/pypi/pdb2pqr
arch = any
license = BSD
@@ -13,8 +13,10 @@ pkgbase = python-pdb2pqr
options = !emptydirs
source = https://files.pythonhosted.org/packages/source/p/pdb2pqr/pdb2pqr-3.0.1.tar.gz
source = fix_entrypoint.patch
+ source = fix_matchedatoms.patch
sha256sums = 15ac0ce77dc17fb459092aca12cc7c2c070904f77914f1197282e28f418b6bd0
sha256sums = bb177e8fb9a31f2486e5682ae97139ebf87948fb4dc33dc892e90ff606df7211
+ sha256sums = 8708438980e5dda5036d2c4fa404d1817104ebbf0443f7798a2698b75a38fe9c
pkgname = python-pdb2pqr
diff --git a/PKGBUILD b/PKGBUILD
index 237145672d6e..e91c130c296d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-pdb2pqr
_name=${pkgname#python-}
pkgver=3.0.1
-pkgrel=2
+pkgrel=3
pkgdesc="Automates many of the common tasks of preparing structures for continuum solvation calculations as well as many other types of biomolecular structure modeling, analysis, and simulation."
arch=(any)
url="http://pypi.python.org/pypi/${_name}"
@@ -11,14 +11,17 @@ license=(BSD)
depends=('python>=3.5' 'python-propka>=3.2' 'python-pandas>=1.0' 'python-pytest>=5.4.1')
makedepends=(patch)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
- "fix_entrypoint.patch")
+ "fix_entrypoint.patch"
+ "fix_matchedatoms.patch")
sha256sums=('15ac0ce77dc17fb459092aca12cc7c2c070904f77914f1197282e28f418b6bd0'
- 'bb177e8fb9a31f2486e5682ae97139ebf87948fb4dc33dc892e90ff606df7211')
+ 'bb177e8fb9a31f2486e5682ae97139ebf87948fb4dc33dc892e90ff606df7211'
+ '8708438980e5dda5036d2c4fa404d1817104ebbf0443f7798a2698b75a38fe9c')
options=(!emptydirs)
prepare() {
cd "${srcdir}/${_name}-${pkgver}"
patch -Np0 -i "${srcdir}/fix_entrypoint.patch"
+ patch -Np0 -i "${srcdir}/fix_matchedatoms.patch"
}
build() {
diff --git a/fix_matchedatoms.patch b/fix_matchedatoms.patch
new file mode 100644
index 000000000000..ce1b64135cf0
--- /dev/null
+++ b/fix_matchedatoms.patch
@@ -0,0 +1,34 @@
+--- pdb2pqr/main.py 2020-08-25 20:53:35.000000000 +0300
++++ pdb2pqr/main.py 2020-08-25 21:15:39.017396736 +0300
+@@ -470,17 +470,16 @@
+ hydrogen_routines.optimize_hydrogens()
+ hydrogen_routines.cleanup()
+
+ _LOGGER.info("Applying force field to biomolecule states.")
+ protein.set_states()
+- hitlist, misslist = protein.apply_force_field(forcefield_)
++ matched_atoms, missing_atoms = protein.apply_force_field(forcefield_)
+
+ if args.ligand is not None:
+ _LOGGER.info("Processing ligand.")
+ _LOGGER.warning("Using ZAP9 forcefield for ligand radii.")
+ ligand.assign_parameters()
+- missing_atoms = []
+ lig_atoms = []
+ for residue in protein.residues:
+ tot_charge = 0
+ for pdb_atom in residue.atoms:
+ # Only check residues with HETATM
+@@ -497,11 +496,11 @@
+ "Can't find HETATM {r.name} {r.res_seq} {a.name} "
+ "in MOL2 file").format(r=residue, a=pdb_atom)
+ _LOGGER.warning(err)
+ missing_atoms.append(pdb_atom)
+
+- matched_atoms = hitlist + lig_atoms
++ matched_atoms += lig_atoms
+
+ for residue in protein.residues:
+ if not isclose(
+ residue.charge, int(residue.charge), abs_tol=CHARGE_ERROR):
+ err = (