summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-08-25 18:03:07 +0300
committerViktor Drobot2020-08-25 18:03:07 +0300
commit8372b0b73bbe3f5c8205b764cd125f2f579d05f5 (patch)
treeae16a1871735ac6f780b8c5b943cdee71f359d3a
downloadaur-8372b0b73bbe3f5c8205b764cd125f2f579d05f5.tar.gz
Initial release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b041655a2a28
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-pdb2pqr
+ pkgdesc = Automates many of the common tasks of preparing structures for continuum solvation calculations as well as many other types of biomolecular structure modeling, analysis, and simulation.
+ pkgver = 3.0.1
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/pdb2pqr
+ arch = any
+ license = BSD
+ depends = python>=3.5
+ depends = python-propka>=3.2
+ depends = python-pandas>=1.0
+ depends = python-pytest>=5.4.1
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/source/p/pdb2pqr/pdb2pqr-3.0.1.tar.gz
+ sha256sums = 15ac0ce77dc17fb459092aca12cc7c2c070904f77914f1197282e28f418b6bd0
+
+pkgname = python-pdb2pqr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e06b729b99dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+pkgname=python-pdb2pqr
+_name=${pkgname#python-}
+pkgver=3.0.1
+pkgrel=1
+pkgdesc="Automates many of the common tasks of preparing structures for continuum solvation calculations as well as many other types of biomolecular structure modeling, analysis, and simulation."
+arch=(any)
+url="http://pypi.python.org/pypi/${_name}"
+license=(BSD)
+depends=('python>=3.5' 'python-propka>=3.2' 'python-pandas>=1.0' 'python-pytest>=5.4.1')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('15ac0ce77dc17fb459092aca12cc7c2c070904f77914f1197282e28f418b6bd0')
+options=(!emptydirs)
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+