summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2021-01-27 20:11:47 +0300
committerViktor Drobot2021-01-27 20:11:47 +0300
commit9f18cc64cb379622f8fbc8c11e1ff118f2b6e385 (patch)
tree060b42c6250fa90bb171e32db0ee75e256e10826
parent6324f0d79939fbb7f148786e47bd8650da2e1e29 (diff)
downloadaur-9f18cc64cb379622f8fbc8c11e1ff118f2b6e385.tar.gz
Update 3.1.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
-rw-r--r--fix_entrypoint.patch74
-rw-r--r--fix_matchedatoms.patch34
4 files changed, 8 insertions, 132 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea068f952069..45a7ce8a2c17 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,17 @@
pkgbase = python-pdb2pqr
pkgdesc = Automates many of the common tasks of preparing structures for continuum solvation calculations as well as many other types of biomolecular structure modeling, analysis, and simulation.
- pkgver = 3.0.1
- pkgrel = 3
+ pkgver = 3.1.0
+ pkgrel = 1
url = http://pypi.python.org/pypi/pdb2pqr
arch = any
license = BSD
- makedepends = patch
depends = python>=3.5
depends = python-propka>=3.2
depends = python-pandas>=1.0
depends = python-pytest>=5.4.1
options = !emptydirs
- source = https://files.pythonhosted.org/packages/source/p/pdb2pqr/pdb2pqr-3.0.1.tar.gz
- source = fix_entrypoint.patch
- source = fix_matchedatoms.patch
- sha256sums = 15ac0ce77dc17fb459092aca12cc7c2c070904f77914f1197282e28f418b6bd0
- sha256sums = bb177e8fb9a31f2486e5682ae97139ebf87948fb4dc33dc892e90ff606df7211
- sha256sums = 8708438980e5dda5036d2c4fa404d1817104ebbf0443f7798a2698b75a38fe9c
+ source = https://files.pythonhosted.org/packages/source/p/pdb2pqr/pdb2pqr-3.1.0.tar.gz
+ sha256sums = a6f5e2eefbd8bd2a072a89ee4026977de02dadd56e921095afac88d596b63820
pkgname = python-pdb2pqr
diff --git a/PKGBUILD b/PKGBUILD
index e91c130c296d..4802c3024617 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,17 @@
pkgname=python-pdb2pqr
_name=${pkgname#python-}
-pkgver=3.0.1
-pkgrel=3
+pkgver=3.1.0
+pkgrel=1
pkgdesc="Automates many of the common tasks of preparing structures for continuum solvation calculations as well as many other types of biomolecular structure modeling, analysis, and simulation."
arch=(any)
url="http://pypi.python.org/pypi/${_name}"
license=(BSD)
depends=('python>=3.5' 'python-propka>=3.2' 'python-pandas>=1.0' 'python-pytest>=5.4.1')
-makedepends=(patch)
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
- "fix_entrypoint.patch"
- "fix_matchedatoms.patch")
-sha256sums=('15ac0ce77dc17fb459092aca12cc7c2c070904f77914f1197282e28f418b6bd0'
- 'bb177e8fb9a31f2486e5682ae97139ebf87948fb4dc33dc892e90ff606df7211'
- '8708438980e5dda5036d2c4fa404d1817104ebbf0443f7798a2698b75a38fe9c')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('a6f5e2eefbd8bd2a072a89ee4026977de02dadd56e921095afac88d596b63820')
options=(!emptydirs)
-prepare() {
- cd "${srcdir}/${_name}-${pkgver}"
- patch -Np0 -i "${srcdir}/fix_entrypoint.patch"
- patch -Np0 -i "${srcdir}/fix_matchedatoms.patch"
-}
-
build() {
cd "${srcdir}/${_name}-${pkgver}"
python setup.py build
diff --git a/fix_entrypoint.patch b/fix_entrypoint.patch
deleted file mode 100644
index cb004817eb72..000000000000
--- a/fix_entrypoint.patch
+++ /dev/null
@@ -1,74 +0,0 @@
---- pdb2pqr/__init__.py 2020-07-03 20:02:43.000000000 +0300
-+++ pdb2pqr/__init__.py 2020-08-25 20:48:59.940600307 +0300
-@@ -6,11 +6,11 @@
- For more information, see http://www.poissonboltzmann.org/
- """
- import logging
- from sys import version_info
- assert version_info >= (3, 5)
--from .main import main, build_parser
-+from .main import main_driver, build_parser
-
-
- _LOGGER = logging.getLogger(__name__)
- logging.captureWarnings(True)
-
-@@ -18,6 +18,6 @@
- if __name__ == "__main__":
- logging.basicConfig(level=logging.DEBUG)
- logging.captureWarnings(True)
- parser = build_parser()
- args = parser.parse_args()
-- main(args)
-+ main_driver(args)
---- pdb2pqr/__main__.py 2020-07-03 20:02:43.000000000 +0300
-+++ pdb2pqr/__main__.py 2020-08-25 20:49:15.213902523 +0300
-@@ -6,11 +6,11 @@
- For more information, see http://www.poissonboltzmann.org/
- """
- import logging
- from sys import version_info
- assert version_info >= (3, 5)
--from pdb2pqr.main import main, build_parser
-+from pdb2pqr.main import main_driver, build_parser
-
-
- _LOGGER = logging.getLogger(__name__)
- logging.captureWarnings(True)
-
-@@ -18,6 +18,6 @@
- if __name__ == "__main__":
- logging.basicConfig(level=logging.DEBUG)
- logging.captureWarnings(True)
- parser = build_parser()
- args = parser.parse_args()
-- main(args)
-+ main_driver(args)
---- pdb2pqr/main.py 2020-07-03 20:02:43.000000000 +0300
-+++ pdb2pqr/main.py 2020-08-25 20:50:27.673754924 +0300
-@@ -533,11 +533,11 @@
- lines = io.print_protein_atoms(matched_atoms, args.keep_chain)
-
- return {"lines": lines, "header": header, "missed_residues": missing_atoms}
-
-
--def main(args):
-+def main_driver(args):
- """Main driver for running program from the command line.
-
- Validate inputs, launch PDB2PQR, handle output.
-
- Args:
-@@ -581,5 +581,12 @@
- missing_lines=results["missed_residues"], is_cif=is_cif)
-
- if args.apbs_input:
- raise NotImplementedError("Missing argument for APBS input file.")
- io.dump_apbs(args.output_pqr)
-+
-+
-+def main():
-+ """Hook for command-line usage."""
-+ parser = build_parser()
-+ args = parser.parse_args()
-+ main_driver(args)
diff --git a/fix_matchedatoms.patch b/fix_matchedatoms.patch
deleted file mode 100644
index ce1b64135cf0..000000000000
--- a/fix_matchedatoms.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- pdb2pqr/main.py 2020-08-25 20:53:35.000000000 +0300
-+++ pdb2pqr/main.py 2020-08-25 21:15:39.017396736 +0300
-@@ -470,17 +470,16 @@
- hydrogen_routines.optimize_hydrogens()
- hydrogen_routines.cleanup()
-
- _LOGGER.info("Applying force field to biomolecule states.")
- protein.set_states()
-- hitlist, misslist = protein.apply_force_field(forcefield_)
-+ matched_atoms, missing_atoms = protein.apply_force_field(forcefield_)
-
- if args.ligand is not None:
- _LOGGER.info("Processing ligand.")
- _LOGGER.warning("Using ZAP9 forcefield for ligand radii.")
- ligand.assign_parameters()
-- missing_atoms = []
- lig_atoms = []
- for residue in protein.residues:
- tot_charge = 0
- for pdb_atom in residue.atoms:
- # Only check residues with HETATM
-@@ -497,11 +496,11 @@
- "Can't find HETATM {r.name} {r.res_seq} {a.name} "
- "in MOL2 file").format(r=residue, a=pdb_atom)
- _LOGGER.warning(err)
- missing_atoms.append(pdb_atom)
-
-- matched_atoms = hitlist + lig_atoms
-+ matched_atoms += lig_atoms
-
- for residue in protein.residues:
- if not isclose(
- residue.charge, int(residue.charge), abs_tol=CHARGE_ERROR):
- err = (