summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKherim Willems2023-05-07 12:56:07 +0200
committerKherim Willems2023-05-07 12:56:07 +0200
commita40ec80db87d0aba5432658476b9003b25649f8f (patch)
treec39e86c85b81235ac207552f6bde5ddf60c10e1c
parent520ca79b477ea363f4257012b93e8e5a5408d6cd (diff)
downloadaur-a40ec80db87d0aba5432658476b9003b25649f8f.tar.gz
Updated to v3.6.1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD10
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28787f50cef2..fb23ad124d27 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = python-pdb2pqr
pkgdesc = Automates many of the common tasks of preparing structures for continuum solvation calculations as well as many other types of biomolecular structure modeling, analysis, and simulation.
- pkgver = 3.5.2
+ pkgver = 3.6.1
pkgrel = 1
url = http://pypi.python.org/pypi/pdb2pqr
arch = any
license = BSD
- depends = python>=3.6
+ checkdepends = python-pandas>=1.0
+ checkdepends = python-pytest
+ checkdepends = python-testfixtures
+ depends = python>=3.5
+ depends = python-mmcif-pdbx>=1.1.2
depends = python-numpy
+ depends = python-propka>=3.5
depends = python-requests
depends = python-docutils
- depends = python-propka>=3.2
- depends = python-pandas>=1.0
- depends = python-pytest>=5.4.1
- depends = python-mmcif-pdbx>=1.1.2
options = !emptydirs
- source = https://files.pythonhosted.org/packages/source/p/pdb2pqr/pdb2pqr-3.5.2.tar.gz
- sha256sums = 9d145ff3797a563ce818f9d2488413ac339f66c58230670c2455b2572cccd957
+ source = https://files.pythonhosted.org/packages/source/p/pdb2pqr/pdb2pqr-3.6.1.tar.gz
+ sha256sums = c056a4e6d28eb0f6117e5056f2f89612333a0a4bb9264581ea6595c883588758
pkgname = python-pdb2pqr
diff --git a/PKGBUILD b/PKGBUILD
index 4703280cde30..edb3bb215958 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,17 @@
pkgname=python-pdb2pqr
_name=${pkgname#python-}
-pkgver=3.5.2
+pkgver=3.6.1
pkgrel=1
pkgdesc="Automates many of the common tasks of preparing structures for continuum solvation calculations as well as many other types of biomolecular structure modeling, analysis, and simulation."
arch=(any)
url="http://pypi.python.org/pypi/${_name}"
license=(BSD)
-depends=('python>=3.6' python-numpy python-requests python-docutils
- 'python-propka>=3.2' 'python-pandas>=1.0' 'python-pytest>=5.4.1'
- 'python-mmcif-pdbx>=1.1.2')
+depends=('python>=3.5' 'python-mmcif-pdbx>=1.1.2' python-numpy
+ 'python-propka>=3.5' python-requests python-docutils)
+checkdepends=('python-pandas>=1.0' python-pytest python-testfixtures)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('9d145ff3797a563ce818f9d2488413ac339f66c58230670c2455b2572cccd957')
+sha256sums=('c056a4e6d28eb0f6117e5056f2f89612333a0a4bb9264581ea6595c883588758')
options=(!emptydirs)
build() {