summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsga0132024-11-18 00:02:43 +0530
committersga0132024-11-18 00:02:43 +0530
commitc6b9e369411129f6362bd57cd5c6988431ced02c (patch)
tree78e86ce223dc83b37d094b4bda98c5760a0a6b49
downloadaur-c6b9e369411129f6362bd57cd5c6988431ced02c.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD25
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..777a5ac1daa1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-pdf2bib
+ pkgdesc = A python library/command-line tool to quickly and automatically generate BibTeX data starting from the pdf file of a scientific publication.
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://github.com/MicheleCotrufo/pdf2bib
+ arch = any
+ license = unknown
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python
+ depends = python-bibtexparser
+ depends = python-pyperclip
+ depends = python-unidecode
+ depends = python-pdf2doi
+ source = https://files.pythonhosted.org/packages/86/58/2ed869b6aab7c8f555130bafbabe50562f0c11aa486a35d608c7baef0910/pdf2bib-1.2.tar.gz
+ sha256sums = 3fd4d9e99585a3ba2115892d3e2fac132151f7bd9c7e1f2ffae5c54ec22c66cc
+
+pkgname = python-pdf2bib
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef8ca5b2d39c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: sga013
+pkgname='python-pdf2bib'
+_module='pdf2bib'
+_src_folder='pdf2bib-1.2'
+pkgver='1.2'
+pkgrel=1
+pkgdesc="A python library/command-line tool to quickly and automatically generate BibTeX data starting from the pdf file of a scientific publication."
+url="https://github.com/MicheleCotrufo/pdf2bib"
+depends=('python' 'python-bibtexparser' 'python-pyperclip' 'python-unidecode' 'python-pdf2doi')
+makedepends=('python-build' 'python-installer' 'python-wheel')
+license=('unknown')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/86/58/2ed869b6aab7c8f555130bafbabe50562f0c11aa486a35d608c7baef0910/pdf2bib-1.2.tar.gz")
+sha256sums=('3fd4d9e99585a3ba2115892d3e2fac132151f7bd9c7e1f2ffae5c54ec22c66cc')
+
+build() {
+ cd "${srcdir}/${_src_folder}"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+
+ cd "${srcdir}/${_src_folder}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+}