summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSumner Evans2018-07-13 23:52:04 -0600
committerSumner Evans2018-07-13 23:52:04 -0600
commit3f6df6365b13fc67783ad65b63215a5eb249d670 (patch)
tree81c9742de724dc3e59acaf24ef3d498412957ad3
parentfaf51690186e8792f9e34339d238a5c05156b93b (diff)
downloadaur-3f6df6365b13fc67783ad65b63215a5eb249d670.tar.gz
Added update script to make updating versions easier
-rw-r--r--PKGBUILD12
-rwxr-xr-xupdate.sh64
2 files changed, 72 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ebbacecb9250..dbe18946c13a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,19 @@ pkgname=('python-pdfkit')
_module='pdfkit'
pkgver='0.6.1'
pkgrel=1
-pkgdesc="Wkhtmltopdf python wrapper to convert html to pdf using the webkit rendering engine and qt"
-url="https://github.com/JazzCore/python-pdfkit"
-depends=('python' 'wkhtmltopdf')
+pkgdesc='Wkhtmltopdf python wrapper to convert html to pdf using the webkit rendering engine and qt'
+url='https://github.com/JazzCore/python-pdfkit'
+depends=(
+ 'python'
+ 'wkhtmltopdf'
+)
makedepends=('python-setuptools')
license=('MIT')
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/p/pdfkit/pdfkit-${pkgver}.tar.gz")
+source=('https://files.pythonhosted.org/packages/source/p/pdfkit/pdfkit-0.6.1.tar.gz')
sha256sums=('ef1da35b78d534197e7ce4a604a4a190e9aa769e56634957535f3479a50d8cd1')
+
build() {
cd "${srcdir}/${_module}-${pkgver}"
python setup.py build
diff --git a/update.sh b/update.sh
new file mode 100755
index 000000000000..f29cefd9c46c
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,64 @@
+#! /bin/sh
+
+AUR_NAME=python-pdfkit
+PROJ_NAME=pdfkit
+DESCRIPTION="Wkhtmltopdf python wrapper to convert html to pdf using the webkit rendering engine and qt"
+URL='https://github.com/JazzCore/python-pdfkit'
+DEPENDS=(wkhtmltopdf)
+LICENSE='MIT'
+ADDITIONAL=
+
+if [[ $# == 0 ]]; then
+ echo 'Usage: ./update.sh VERSION_NUMBER'
+ exit 1
+fi
+
+src=https://files.pythonhosted.org/packages/source/${PROJ_NAME:0:1}/${PROJ_NAME}/${PROJ_NAME}-$1.tar.gz
+
+# Get the sha256sum sum of the package.
+mkdir -p dist
+pushd dist
+wget $src
+sha=$(sha256sum "${PROJ_NAME}-$1.tar.gz" | cut -d ' ' -f 1)
+popd
+
+echo "# Maintainer: Sumner Evans <sumner.evans98 at gmail dot com>
+
+pkgbase=('${AUR_NAME}')
+pkgname=('${AUR_NAME}')
+_module='${PROJ_NAME}'
+pkgver='$1'
+pkgrel=1
+pkgdesc='${DESCRIPTION}'
+url='${URL}'
+depends=(
+ 'python'" > PKGBUILD
+
+# Include the dependencies.
+for d in ${DEPENDS[*]}; do
+ echo " '$d'" >> PKGBUILD
+done
+
+echo ")
+makedepends=('python-setuptools')
+license=('${LICENSE}')
+arch=('any')
+source=('${src}')
+sha256sums=('${sha}')
+${ADDITIONAL}
+
+build() {
+ cd \"\${srcdir}/\${_module}-\${pkgver}\"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd \"\${srcdir}/\${_module}-\${pkgver}\"
+ python setup.py install --root=\"\${pkgdir}\" --optimize=1 --skip-build
+}" >> PKGBUILD
+
+make
+
+# Test
+makepkg -f