summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsga0132024-11-17 23:39:50 +0530
committersga0132024-11-17 23:39:50 +0530
commitaba33493cb60052e388b7d3d839442eb150b8602 (patch)
tree8db9af4160739db4bf599a5f2a3052f9c6519825
downloadaur-aba33493cb60052e388b7d3d839442eb150b8602.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cba884db95a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-pdftitle
+ pkgdesc = pdftitle is a small utility to extract the title from a PDF file
+ pkgver = 0.16
+ pkgrel = 1
+ url = https://github.com/metebalci/pdftitle
+ arch = any
+ license = GPLv3
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python
+ depends = python-pdfminer
+ source = https://files.pythonhosted.org/packages/b1/3b/7a71962cc31c515562256361cce465a349ce3531f6484bf30fef2baa9ca6/pdftitle-0.16.tar.gz
+ sha256sums = 6b036efefc7045799e3c677a0d5c0694ce0d294e0feb6c219ba77dbd3f86e8f8
+
+pkgname = python-pdftitle
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e8983afb4f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: sga013
+pkgname='python-pdftitle'
+_module='pdftitle'
+_src_folder='pdftitle-0.16'
+pkgver='0.16'
+pkgrel=1
+pkgdesc="pdftitle is a small utility to extract the title from a PDF file"
+url="https://github.com/metebalci/pdftitle"
+depends=('python' 'python-pdfminer')
+makedepends=('python-build' 'python-installer' 'python-wheel')
+license=('GPLv3')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/b1/3b/7a71962cc31c515562256361cce465a349ce3531f6484bf30fef2baa9ca6/pdftitle-0.16.tar.gz")
+sha256sums=('6b036efefc7045799e3c677a0d5c0694ce0d294e0feb6c219ba77dbd3f86e8f8')
+
+build() {
+ cd "${srcdir}/${_src_folder}"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+
+ cd "${srcdir}/${_src_folder}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+}
+
+