summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcarlwgeorge2017-07-08 17:06:56 -0500
committercarlwgeorge2017-07-08 17:09:41 -0500
commita133b3693961973d3b910e55efab1a1ba8c1fc18 (patch)
treea2488a896f81044e0cf547d2deeb0a88c3da69cf
parent8eadc4e6975d37858ae47e36b20d52818772f6a2 (diff)
downloadaur-a133b3693961973d3b910e55efab1a1ba8c1fc18.tar.gz
0.2.2-1
* changed source to https://pypi.org/project/pdir/ (search the AUR for pdir2 for the previous package) * upstream isn't compatible with PY3, so remove PY3 subpackage
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD39
3 files changed, 32 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29ab3d23cba1..4cf8ae65ab37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
# Generated by mksrcinfo v8
-# Wed Jul 5 16:46:10 UTC 2017
+# Sat Jul 8 22:09:25 UTC 2017
pkgbase = python-pdir
- pkgdesc = Pretty dir printing with joy
- pkgver = 0.2.1
+ pkgdesc = A selective pretty dir printing utility for Python
+ pkgver = 0.2.2
pkgrel = 1
- url = https://github.com/laike9m/pdir2
+ url = https://github.com/pramttl/pdir
arch = any
- license = MIT
+ license = BSD
makedepends = python-setuptools
makedepends = python2-setuptools
- source = https://files.pythonhosted.org/packages/source/p/pdir2/pdir2-0.2.1.tar.gz
- sha256sums = baaf07033f71efddb1d1d8f63c4b3a3e66415ed91fb4f8895e746c0cc5c89238
-
-pkgname = python-pdir
- depends = python
+ source = https://files.pythonhosted.org/packages/source/p/pdir/pdir-0.2.2.tar.gz
+ source = https://raw.githubusercontent.com/pramttl/pdir/master/LICENSE.txt
+ sha256sums = 43e7fdd73807b17c58f548db04eabba8cbea4033582a42b9d3c98ceda1fbfffb
+ sha256sums = 4c43622e8623588a38649c02856603b9fbe932c2c9f9cd7694278bc36a332c16
pkgname = python2-pdir
depends = python2
- depends = python2-enum34
diff --git a/.gitignore b/.gitignore
index cb20ebe4ea4a..fef209235fcd 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,11 +1,12 @@
# sources
*.tar.gz
-LICENSE
+LICENSE.txt
# build logs
*-build.log
*-namcap.log
*-package*.log
+*-prepare.log
# packages
*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 33d2ba4cac01..69d210f5f92b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,38 @@
# Maintainer: Carl George < arch at cgtx dot us >
-_name="pdir2"
-_module="${_name%2}"
+_name="pdir"
-pkgname=("python-$_module" "python2-$_module")
-pkgver=0.2.1
+#pkgname=("python-$_name" "python2-$_name")
+pkgbase="python-$_name"
+pkgname=("python2-$_name")
+pkgver=0.2.2
pkgrel=1
-pkgdesc="Pretty dir printing with joy"
+pkgdesc="A selective pretty dir printing utility for Python"
arch=("any")
-url="https://github.com/laike9m/$_name"
-license=("MIT")
+url="https://github.com/pramttl/$_name"
+license=("BSD")
makedepends=("python-setuptools" "python2-setuptools")
-source=("https://files.pythonhosted.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('baaf07033f71efddb1d1d8f63c4b3a3e66415ed91fb4f8895e746c0cc5c89238')
+source=("https://files.pythonhosted.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz"
+ "https://raw.githubusercontent.com/pramttl/pdir/master/LICENSE.txt")
+sha256sums=('43e7fdd73807b17c58f548db04eabba8cbea4033582a42b9d3c98ceda1fbfffb'
+ '4c43622e8623588a38649c02856603b9fbe932c2c9f9cd7694278bc36a332c16')
build() {
cd "$_name-$pkgver"
- python setup.py build
+ #python setup.py build
python2 setup.py build
}
-package_python-pdir() {
- depends=("python")
- cd "$_name-$pkgver"
- python setup.py install --skip-build --root="$pkgdir" --optimize=1
- install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
-}
+#package_python-pdir() {
+# depends=("python")
+# cd "$_name-$pkgver"
+# python setup.py install --skip-build --root="$pkgdir" --optimize=1
+# install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" "$srcdir/LICENSE.txt"
+#}
package_python2-pdir() {
- depends=("python2" "python2-enum34")
+ depends=("python2")
cd "$_name-$pkgver"
python2 setup.py install --skip-build --root="$pkgdir" --optimize=1
- install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" "$srcdir/LICENSE.txt"
}