summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel M. Capella2022-02-20 01:22:21 +0000
committerDaniel M. Capella2022-02-20 01:22:21 +0000
commitf69221cdf2d6c8e4bdaa9cb78b83d9a0526fb111 (patch)
tree37800c72a4f181135e74261c6ca4310dc4c41a3f
parent7c6ada556474057a58bfec81d7b4a05a8522e9c4 (diff)
downloadaur-f69221cdf2d6c8e4bdaa9cb78b83d9a0526fb111.tar.gz
Switch to python-installer from python-install
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ba8a70f0e083..03db78be80ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ arch=(any)
url="https://github.com/pdm-project/pdm-pep517"
license=(MIT)
depends=(python-cerberus python-packaging python-toml)
-makedepends=(python-build python-install)
+makedepends=(python-build python-installer)
checkdepends=(git python-pytest python-setuptools)
optdepends=(
'python-setuptools: for setuptools support'
@@ -47,7 +47,7 @@ check() {
package() {
cd "$_name-$pkgver"
- python -m install --optimize=1 --destdir="$pkgdir" dist/*.whl
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -vDm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}/"
install -vDm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}/"
}