summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPayson Wallach2019-11-13 16:00:09 -0600
committerPayson Wallach2019-11-13 16:10:42 -0600
commitc863d413487f0eff2cf3a291a25ed1de7f702f2b (patch)
treed857f2f3595f89e41efdd7f19860b0608d818b82
downloadaur-c863d413487f0eff2cf3a291a25ed1de7f702f2b.tar.gz
Initial commit
Add .SRCINFO Add .gitignore
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a5bf2d01395
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-persist-queue
+ pkgdesc = A thread-safe disk based persistent queue in Python.
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = http://github.com/peter-wangxu/persist-queue
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/p/persist-queue/persist-queue-0.5.0.tar.gz
+ md5sums = 3644ef1a990c29ced4e62b5c4672126a
+
+pkgname = python-persist-queue
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..591d239c0d22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Payson Wallach <payson@paysonwallach.com>
+
+_name=persist-queue
+pkgname=python-persist-queue
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="A thread-safe disk based persistent queue in Python."
+arch=(any)
+url="http://github.com/peter-wangxu/persist-queue"
+license=('BSD')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+md5sums=('3644ef1a990c29ced4e62b5c4672126a')
+
+build() {
+ cd $_name-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $_name-$pkgver
+ python setup.py install --skip-build --root="$pkgdir/" --optimize=1
+}