summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Vuillard2016-09-22 22:28:10 +0200
committerArthur Vuillard2016-09-22 22:28:10 +0200
commita236ac9c078befc236e164d03045f6e34d40e29a (patch)
tree1a7d282f36a78bb7d38f268d796727b350562d33
downloadaur-a236ac9c078befc236e164d03045f6e34d40e29a.tar.gz
release 0.3
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD21
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0d0138b9436
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-persistentlist
+ pkgdesc = Persistentlist is a simple persistent list carrying n objects, the last objects being appended at the end of the list.
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://github.com/chaica/persistentlist
+ arch = any
+ license = GPL3
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/chaica/persistentlist/archive/0.3.tar.gz
+ md5sums = ff16d048246e43a15585e1da08d6b460
+
+pkgname = python-persistentlist
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..87b64657ff3e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40dcc8d177db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+_github_name='persistentlist'
+pkgname="python-${_github_name}"
+pkgver=0.3
+pkgrel=1
+pkgdesc="Persistentlist is a simple persistent list carrying n objects, the last objects being appended at the end of the list."
+url="https://github.com/chaica/persistentlist"
+arch=('any')
+license=('GPL3')
+depends=('python')
+makedepends=('python' 'python-setuptools')
+source=(
+ "https://github.com/chaica/${_github_name}/archive/$pkgver.tar.gz"
+)
+
+package() {
+ cd "${srcdir}/${_github_name}-${pkgver}"
+ python3 setup.py build
+ python3 setup.py install --prefix=/usr --root="${pkgdir}"
+}
+
+md5sums=('ff16d048246e43a15585e1da08d6b460')