summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-01-10 23:11:29 -0600
committerLuis Martinez2022-01-10 23:11:29 -0600
commit21bf4c847ff598203e8ea42bd67ede9babc6f4c1 (patch)
tree6469e524c315cf3ad18028172711b719fa0c10f0
parente3f5ac222ad4e4e10bcaa037485782e974c36226 (diff)
downloadaur-21bf4c847ff598203e8ea42bd67ede9babc6f4c1.tar.gz
update to 2.1.62
* drop dephell in favor of pyproject2setuppy
-rw-r--r--.SRCINFO8
-rw-r--r--CHANGES.rst19
-rw-r--r--PKGBUILD14
3 files changed, 28 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a5e9b82072b..af33ea561f47 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = python-pex
pkgdesc = Generates executable Python environments
- pkgver = 2.1.61
+ pkgver = 2.1.62
pkgrel = 1
url = https://github.com/pantsbuild/pex
changelog = CHANGES.rst
arch = any
license = Apache
makedepends = git
- makedepends = python-setuptools
- makedepends = python-dephell
+ makedepends = python-pyproject2setuppy
+ makedepends = python-flit
makedepends = python-sphinx
depends = python
provides = pex
replaces = pex
- source = python-pex::git+https://github.com/pantsbuild/pex#tag=v2.1.61?signed
+ source = python-pex::git+https://github.com/pantsbuild/pex#tag=v2.1.62?signed
validpgpkeys = A1FE765B15233EAD18FA6ABB93E55CB567B5C626
sha256sums = SKIP
diff --git a/CHANGES.rst b/CHANGES.rst
index 35792bd9efc0..90593c9084a3 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,6 +1,25 @@
Release Notes
=============
+2.1.62
+------
+
+This release exposes three Pip options as Pex options to allow building
+PEXes for more of the Python distribution ecosystem:
+
+#. ``--prefer-binary``: To prefer older wheels to newer sdists in a
+ resolve which can help avoid problematic builds.
+#. ``--[no]-use-pep517``: To control how sdists are built: always using
+ PEP-517, always using setup.py or the default, always using whichever
+ is appropriate.
+#. ``--no-build-isolation``: To allow distributions installed in the
+ environment to be seen during builds of sdists. This allows working
+ around distributions with undeclared build dependencies by
+ pre-installing them in the environment before running Pex.
+
+* Expose more Pip options. (#1561)
+ `PR #1561 <https://github.com/pantsbuild/pex/pull/1561>`_
+
2.1.61
------
diff --git a/PKGBUILD b/PKGBUILD
index 2dce224071ca..46613e470eee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
# Contributor: Carlo Cabanilla <carlo.cabanilla@gmail.com>
pkgname=python-pex
-pkgver=2.1.61
+pkgver=2.1.62
pkgrel=1
arch=('any')
pkgdesc='Generates executable Python environments'
url='https://github.com/pantsbuild/pex'
license=('Apache')
depends=('python')
-makedepends=('git' 'python-setuptools' 'python-dephell' 'python-sphinx')
+makedepends=('git' 'python-pyproject2setuppy' 'python-flit' 'python-sphinx')
# checkdepends=('python-pytest-runner' 'python-pkginfo')
changelog=CHANGES.rst
provides=('pex')
@@ -20,14 +20,9 @@ source=("$pkgname::git+$url#tag=v$pkgver?signed")
sha256sums=('SKIP')
validpgpkeys=('A1FE765B15233EAD18FA6ABB93E55CB567B5C626')
-prepare() {
- cd "$pkgname"
- dephell deps convert --from pyproject.toml --to setup.py
-}
-
build() {
cd "$pkgname"
- python setup.py build
+ python -m pyproject2setuppy.main build
cd docs
make man
}
@@ -40,7 +35,8 @@ build() {
# }
package() {
+ export PYTHONHASHSEED=0
cd "$pkgname"
- PYTHONHASHSEED=0 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m pyproject2setuppy.main install --root="$pkgdir/" --optimize=1 --skip-build
install -Dm644 docs/_build/man/pex.1 -t "$pkgdir/usr/share/man/man1/"
}