summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-06-25 23:05:43 -0500
committerLuis Martinez2022-06-25 23:05:43 -0500
commit619fe15d43986cfbc17abc569418118ef86b16e6 (patch)
treede0482bc5aaadc65a834adc512deeded0ff2a641
parent3b7a5dc44f2b6b35ad9f42bf7725b5b47f5840ba (diff)
downloadaur-619fe15d43986cfbc17abc569418118ef86b16e6.tar.gz
update to 2.1.93
-rw-r--r--.SRCINFO4
-rw-r--r--CHANGES.rst47
-rw-r--r--PKGBUILD2
3 files changed, 50 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4541781a5f4..8d065a37dba1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pex
pkgdesc = Generates executable Python environments
- pkgver = 2.1.92
+ pkgver = 2.1.93
pkgrel = 1
url = https://github.com/pantsbuild/pex
changelog = CHANGES.rst
@@ -14,7 +14,7 @@ pkgbase = python-pex
depends = python
provides = pex
replaces = pex
- source = python-pex::git+https://github.com/pantsbuild/pex#tag=v2.1.92?signed
+ source = python-pex::git+https://github.com/pantsbuild/pex#tag=v2.1.93?signed
validpgpkeys = A1FE765B15233EAD18FA6ABB93E55CB567B5C626
sha256sums = SKIP
diff --git a/CHANGES.rst b/CHANGES.rst
index d09e752f40e7..852dd0676a3a 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,6 +1,53 @@
Release Notes
=============
+2.1.93
+------
+
+This release brings several new features in addition to bug fixes.
+
+When creating a PEX the entry point can now be any local python script
+by passing ``--exe path/to/python-script``.
+
+The ``pex3 lock update`` command now supports a ``-dry-dun check`` mode
+that exits non-zero to indicate that a lock needs updating and the
+``-p / --project`` targeted update arguments can now be new projects to
+attempt to add to the lock.
+
+On the bug fix front, traditional zipapp mode PEX files now properly
+scrub ``sys.displayhook`` and ``sys.excepthook`` and their teardown
+sequence has now been simplified fixing logging to stderr late in
+teardown.
+
+Finally, ``pex3 lock create`` now logs when requirement resolution is
+taking a long time to provide some sense of progress and suggest
+generic remedies and ``pex --lock`` now properly handles
+authentication.
+
+* Support adding new requirements in a lock update. (#1797)
+ `PR #1797 <https://github.com/pantsbuild/pex/pull/1797>`_
+
+* Add ``pex3 lock update --dry-run check`` mode. (#1799)
+ `PR #1799 <https://github.com/pantsbuild/pex/pull/1799>`_
+
+* Universal locks no longer record a ``platform_tag``. (#1800)
+ `PR #1800 <https://github.com/pantsbuild/pex/pull/1800>`_
+
+* Support python script file executable. (#1807)
+ `PR #1807 <https://github.com/pantsbuild/pex/pull/1807>`_
+
+* Fix PEX scrubbing to account for sys.excepthook. (#1810)
+ `PR #1810 <https://github.com/pantsbuild/pex/pull/1810>`_
+
+* Simplify ``PEX`` teardown / leave stderr in tact. (#1813)
+ `PR #1813 <https://github.com/pantsbuild/pex/pull/1813>`_
+
+* Surface pip download logging. (#1808)
+ `PR #1808 <https://github.com/pantsbuild/pex/pull/1808>`_
+
+* Use pip download instead or URLFetcher. (#1811)
+ `PR #1811 <https://github.com/pantsbuild/pex/pull/1811>`_
+
2.1.92
------
diff --git a/PKGBUILD b/PKGBUILD
index 5e9746688071..04207891f1ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
## GPG key: https://github.com/jsirois.gpg
pkgname=python-pex
-pkgver=2.1.92
+pkgver=2.1.93
pkgrel=1
arch=('any')
pkgdesc='Generates executable Python environments'