summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-10-03 23:01:01 -0500
committerLuis Martinez2022-10-03 23:01:01 -0500
commit364bc4aa03d4962fcee2156c02e6c5275092d7a6 (patch)
tree4e3b84076bfb264f8d0405fe75841e66e663d8d6
parent5aee344ee46dda1da65ba92e03b891957e458107 (diff)
downloadaur-364bc4aa03d4962fcee2156c02e6c5275092d7a6.tar.gz
update to 0.1.20
-rw-r--r--.SRCINFO9
-rw-r--r--CHANGELOG.md17
-rw-r--r--PKGBUILD6
3 files changed, 25 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 571653537533..28f6d80337cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pgmpy
pkgdesc = Probabilistic Graphical Model library
- pkgver = 0.1.19
+ pkgver = 0.1.20
pkgrel = 1
url = https://github.com/pgmpy/pgmpy
changelog = CHANGELOG.md
@@ -20,6 +20,7 @@ pkgbase = python-pgmpy
depends = python-joblib
depends = python-networkx
depends = python-numpy
+ depends = python-opt_einsum
depends = python-pandas
depends = python-pyparsing
depends = python-scipy
@@ -27,7 +28,9 @@ pkgbase = python-pgmpy
depends = python-statsmodels
depends = python-pytorch
depends = python-tqdm
- source = python-pgmpy-0.1.19.tar.gz::https://github.com/pgmpy/pgmpy/archive/v0.1.19.tar.gz
- sha256sums = 8f642f15c478d08fae07ac499531862acea5b2c11ace0dd7a629d2682826a71b
+ optdepends = python-daft
+ optdepends = python-lxml
+ source = python-pgmpy-0.1.20.tar.gz::https://github.com/pgmpy/pgmpy/archive/v0.1.20.tar.gz
+ sha256sums = 5069daaa472be8de392ba3f5798fe639fc8b6204d3d50baa2bd8d35390ab7250
pkgname = python-pgmpy
diff --git a/CHANGELOG.md b/CHANGELOG.md
index d2e63992fdeb..36f02a6e4588 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -4,7 +4,20 @@ All notable changes to this project will be documented in this file.
The format is based on [Keep a Changelog](https://keepachangelog.com/en/1.0.0/),
and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.html).
-## [0.1.19] - 2021-06-30
+## [0.1.20] - 2022-09-30
+### Added
+1. `BayesianNetwork.get_random_cpds` method to randomly parameterize a network structure.
+2. Faster Variable Elimination using tensor contraction.
+3. `factors.factor_sum_product` method for faster sum-product operations using tensor contraction.
+
+### Fixed
+1. Bug in `DynamicBayesianNetwork.initialize_initial_state`. #1564
+2. Bug in `factors.factor_product`. #1565
+
+### Changed
+1. Runtime improvements in `DiscreteFactor.marginalize` and `DiscreteFactor.copy` methods.
+
+## [0.1.19] - 2022-06-30
### Added
1. Adds checks for arguments to `BayesianNetwork.simulate` method.
@@ -16,7 +29,7 @@ and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0
5. `DAG.active_trail_nodes` allows tuples as variable names.
6. Fixes CPD and edge creation in `UAIReader`.
-## [0.1.18] - 2021-03-30
+## [0.1.18] - 2022-03-30
### Fixed
1. Fixes `CausalInference.is_valid_backdoor_adjustment_set` to accept str arguments for `Z`.
2. Fixes `BayesianNetwork.remove_cpd` to work with integral node names.
diff --git a/PKGBUILD b/PKGBUILD
index 983add8aab97..dde7855a4c78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-pgmpy
_pkg="${pkgname#python-}"
-pkgver=0.1.19
+pkgver=0.1.20
pkgrel=1
pkgdesc="Probabilistic Graphical Model library"
arch=('any')
@@ -13,6 +13,7 @@ depends=(
'python-joblib'
'python-networkx'
'python-numpy'
+ 'python-opt_einsum'
'python-pandas'
'python-pyparsing'
'python-scipy'
@@ -20,6 +21,7 @@ depends=(
'python-statsmodels'
'python-pytorch'
'python-tqdm')
+optdepends=('python-daft' 'python-lxml')
makedepends=(
'python-setuptools'
'python-build'
@@ -31,7 +33,7 @@ makedepends=(
checkdepends=('python-pytest' 'python-mock' 'python-daft')
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('8f642f15c478d08fae07ac499531862acea5b2c11ace0dd7a629d2682826a71b')
+sha256sums=('5069daaa472be8de392ba3f5798fe639fc8b6204d3d50baa2bd8d35390ab7250')
prepare() {
cd "$_pkg-$pkgver"