summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-02-12 18:33:31 -0500
committerCarlos Aznarán Laos2022-02-12 18:33:31 -0500
commit8a7e76c902e203f8858e6fe5e49c93b67fec64a6 (patch)
treefbf5758ec49eb392a21958f3da950a7a3add7d50
parentd78fc0ec288e0aa931776af94a61defdcdd2b296 (diff)
downloadaur-python-phidgets.tar.gz
Drop python2 support
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD40
3 files changed, 24 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c5ed725cdf4..60d322cc178d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,13 @@
pkgbase = python-phidgets
pkgdesc = Python Wrapper library for the Phidgets API
pkgver = 2.1.8
- pkgrel = 1
+ pkgrel = 2
url = https://pypi.python.org/pypi/Phidgets
arch = any
- license = custom: Creative Commons Attribution 2.5 Canada License
+ license = custom
makedepends = python-setuptools
- makedepends = python2-setuptools
- options = !emptydirs
- source = https://pypi.python.org/packages/source/P/Phidgets/Phidgets-2.1.8.tar.gz
- md5sums = 70abc2edef4578842906b6a46eef9ad9
-
-pkgname = python-phidgets
depends = python
+ source = https://pypi.org/packages/source/P/Phidgets/Phidgets-2.1.8.tar.gz
+ sha512sums = 91a6b073f75d0d96c0c8eea226c5946e1da1a157c89cb9f9e15040b59151af7421461e36e8037dd5c80fcc271bec6f93ba4d3919b303de46f13c155632fd5f63
-pkgname = python2-phidgets
- depends = python2
-
+pkgname = python-phidgets
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index f42eac01f53a..82359cead0a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,24 @@
-# Maintainer: Christian Schwarz <me@cschwarz.com>
-pkgbase=python-phidgets
-pkgname=("python-phidgets" "python2-phidgets")
+# Contributor: Christian Schwarz <me@cschwarz.com>
+_base=Phidgets
+pkgname=python-${_base,,}
pkgver=2.1.8
-pkgrel=1
+pkgrel=2
pkgdesc="Python Wrapper library for the Phidgets API"
-arch=('any')
-url="https://pypi.python.org/pypi/Phidgets"
-license=('custom: Creative Commons Attribution 2.5 Canada License')
-makedepends=('python-setuptools' 'python2-setuptools')
-options=(!emptydirs)
-source=("https://pypi.python.org/packages/source/P/Phidgets/Phidgets-$pkgver.tar.gz")
-md5sums=("70abc2edef4578842906b6a46eef9ad9")
+arch=(any)
+url="https://pypi.python.org/pypi/${_base}"
+license=('custom')
+depends=(python)
+makedepends=(python-setuptools)
+source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
+sha512sums=('91a6b073f75d0d96c0c8eea226c5946e1da1a157c89cb9f9e15040b59151af7421461e36e8037dd5c80fcc271bec6f93ba4d3919b303de46f13c155632fd5f63')
-package_python-phidgets() {
- depends=("python")
- cd "$srcdir/Phidgets-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+build() {
+ cd ${_base}-${pkgver}
+ export PYTHONHASHSEED=0
+ python setup.py build
}
-package_python2-phidgets() {
- depends=("python2")
- cd "$srcdir/Phidgets-$pkgver"
- python2 setup.py install --root="$pkgdir/" --optimize=1
+package() {
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
}
-
-
-# vim:set ts=2 sw=2 et: