summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Schwarz2015-10-19 22:54:11 +0200
committerChristian Schwarz2015-10-19 23:06:29 +0200
commitd78fc0ec288e0aa931776af94a61defdcdd2b296 (patch)
treeef9fa98d3dc9af1bc0b6490887ea885aa5e4620c
downloadaur-d78fc0ec288e0aa931776af94a61defdcdd2b296.tar.gz
Initial commit.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c5ed725cdf4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-phidgets
+ pkgdesc = Python Wrapper library for the Phidgets API
+ pkgver = 2.1.8
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/Phidgets
+ arch = any
+ license = custom: Creative Commons Attribution 2.5 Canada License
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/P/Phidgets/Phidgets-2.1.8.tar.gz
+ md5sums = 70abc2edef4578842906b6a46eef9ad9
+
+pkgname = python-phidgets
+ depends = python
+
+pkgname = python2-phidgets
+ depends = python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f42eac01f53a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Christian Schwarz <me@cschwarz.com>
+pkgbase=python-phidgets
+pkgname=("python-phidgets" "python2-phidgets")
+pkgver=2.1.8
+pkgrel=1
+pkgdesc="Python Wrapper library for the Phidgets API"
+arch=('any')
+url="https://pypi.python.org/pypi/Phidgets"
+license=('custom: Creative Commons Attribution 2.5 Canada License')
+makedepends=('python-setuptools' 'python2-setuptools')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/source/P/Phidgets/Phidgets-$pkgver.tar.gz")
+md5sums=("70abc2edef4578842906b6a46eef9ad9")
+
+package_python-phidgets() {
+ depends=("python")
+ cd "$srcdir/Phidgets-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+package_python2-phidgets() {
+ depends=("python2")
+ cd "$srcdir/Phidgets-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+
+# vim:set ts=2 sw=2 et: