summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-04-01 11:56:43 -0500
committerCarlos Aznarán2024-04-01 11:56:43 -0500
commit47f5e60232754fc10d03a16a028a3044aad9f2f4 (patch)
tree8928a7bcfaca6c30213c6c9920843ecfbe5936ff
parent43d896e7e80063f6ff4550d44e2ec9c2adab7f51 (diff)
downloadaur-47f5e60232754fc10d03a16a028a3044aad9f2f4.tar.gz
Bump version to 1.5.0
-rw-r--r--.SRCINFO6
-rw-r--r--.nvchecker.toml4
-rw-r--r--PKGBUILD4
3 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45de481ce437..b5d617987fed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-phiml
pkgdesc = Unified API for machine learning
- pkgver = 1.4.0
+ pkgver = 1.5.0
pkgrel = 1
url = https://github.com/tum-pbs/PhiML
arch = any
@@ -16,7 +16,7 @@ pkgbase = python-phiml
depends = python-numpy
depends = python-scipy
depends = python-packaging
- source = PhiML-1.4.0.tar.gz::https://github.com/tum-pbs/PhiML/archive/1.4.0.tar.gz
- sha512sums = 02c2966c73d8b5e0ec95a561d6efd74730f9eda59312aab7f2de6369d54ac960d59d80d4b5f233cf3c7110e0e8dddac3313700bc653d4ed19e25332b0c17cdcc
+ source = PhiML-1.5.0.tar.gz::https://github.com/tum-pbs/PhiML/archive/1.5.0.tar.gz
+ sha512sums = 6fc7b0cef6c65f68779a71cf7b00ac65268ca7690c9e64c1383ab7f2ef461cb312194d00be47c0ce9c06c00a7e6929891270f6ad6ce267720f483b5b5174954d
pkgname = python-phiml
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..786ffee28c67
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,4 @@
+[python-phiml]
+source = "github"
+github = "tum-pbs/PhiML"
+use_latest_release = true
diff --git a/PKGBUILD b/PKGBUILD
index da4701306b05..7002e888d2db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
_base=PhiML
pkgname=python-${_base,,}
-pkgver=1.4.0
+pkgver=1.5.0
pkgrel=1
pkgdesc="Unified API for machine learning"
arch=(any)
@@ -11,7 +11,7 @@ depends=(python-numpy python-scipy python-packaging)
makedepends=(python-build python-installer python-setuptools python-wheel)
checkdepends=(python-pytest python-pytorch python-tensorflow python-jax)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
-sha512sums=('02c2966c73d8b5e0ec95a561d6efd74730f9eda59312aab7f2de6369d54ac960d59d80d4b5f233cf3c7110e0e8dddac3313700bc653d4ed19e25332b0c17cdcc')
+sha512sums=('6fc7b0cef6c65f68779a71cf7b00ac65268ca7690c9e64c1383ab7f2ef461cb312194d00be47c0ce9c06c00a7e6929891270f6ad6ce267720f483b5b5174954d')
build() {
cd ${_base}-${pkgver}