summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2018-09-09 17:43:18 +0800
committerUniversebenzene2018-09-09 17:43:18 +0800
commit2f12736197cccafe0a952d689485d81dd44215ab (patch)
tree0733ac539fbecf9b248dc0b0c4a1d6b4bbaf47b2
parent69651c282e3d21870695085d05c9a542aba9fe4d (diff)
downloadaur-2f12736197cccafe0a952d689485d81dd44215ab.tar.gz
Update to version 0.5, remove python2
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD47
2 files changed, 20 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d7421f5f75f..75fc68237795 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,49 +1,35 @@
# Generated by mksrcinfo v8
-# Thu Feb 15 15:06:46 UTC 2018
+# Sun Sep 9 09:18:06 UTC 2018
pkgbase = python-photutils
pkgdesc = Astropy Affiliated package for image photometry utilities
- pkgver = 0.4
+ pkgver = 0.5
pkgrel = 1
url = http://photutils.readthedocs.io/en/latest/
arch = i686
arch = x86_64
license = BSD
+ checkdepends = python-pytest-astropy
makedepends = cython
- makedepends = cython2
makedepends = python-numpy
- makedepends = python2-numpy
makedepends = python-astropy
makedepends = python-scikit-learn
makedepends = python-scikit-image
makedepends = python-astropy-helpers
- makedepends = python2-astropy-helpers
- makedepends = python-sphinx
+ makedepends = python-sphinx-astropy
makedepends = python-matplotlib
- source = https://files.pythonhosted.org/packages/source/p/photutils/photutils-0.4.tar.gz
- md5sums = ce5ff436d0d8d394bfa6648009f14d37
+ makedepends = python-dask
+ source = https://files.pythonhosted.org/packages/source/p/photutils/photutils-0.5.tar.gz
+ md5sums = a09edbd9e770f4497a00e48c6f4561af
pkgname = python-photutils
- depends = python>=3.4
- depends = python-numpy>=1.9
+ depends = python>=3.5
+ depends = python-numpy>=1.10
depends = python-astropy>=2.0
depends = python-six
optdepends = python-scipy>=0.16: For full functionality
optdepends = python-scikit-image>=0.11: For full functionality
optdepends = python-scikit-learn>=0.18: For full functionality
optdepends = python-matplotlib>=1.3: For full functionality
- optdepends = python-pytest-astropy: For testing
- optdepends = python-photutils-doc: Documentation for python-photutils
-
-pkgname = python2-photutils
- depends = python2>=2.7
- depends = python2-numpy>=1.9
- depends = python2-astropy>=2.0
- depends = python2-six
- optdepends = python2-scipy>=0.16: For full functionality
- optdepends = python2-scikit-image>=0.11: For full functionality
- optdepends = python2-scikit-learn>=0.18: For full functionality
- optdepends = python2-matplotlib>=1.3: For full functionality
- optdepends = python2-pytest: For testing
optdepends = python-photutils-doc: Documentation for python-photutils
pkgname = python-photutils-doc
diff --git a/PKGBUILD b/PKGBUILD
index ce228d0b1423..c4366f155e46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,24 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgbase=python-photutils
-pkgname=('python-photutils' 'python2-photutils' 'python-photutils-doc')
-pkgver=0.4
+pkgname=('python-photutils' 'python-photutils-doc')
+pkgver=0.5
pkgrel=1
pkgdesc="Astropy Affiliated package for image photometry utilities"
arch=('i686' 'x86_64')
url="http://photutils.readthedocs.io/en/latest/"
license=('BSD')
-makedepends=('cython' 'cython2' 'python-numpy' 'python2-numpy' 'python-astropy' 'python-scikit-learn' 'python-scikit-image' 'python-astropy-helpers' 'python2-astropy-helpers' 'python-sphinx' 'python-matplotlib')
-#checkdepends=('python-pytest-astropy' 'python2-pytest' 'python2-astropy')
+makedepends=('cython' 'python-numpy' 'python-astropy' 'python-scikit-learn' 'python-scikit-image' 'python-astropy-helpers' 'python-sphinx-astropy' 'python-matplotlib' 'python-dask')
+checkdepends=('python-pytest-astropy')
source=("https://files.pythonhosted.org/packages/source/p/photutils/photutils-${pkgver}.tar.gz")
-md5sums=('ce5ff436d0d8d394bfa6648009f14d37')
+md5sums=('a09edbd9e770f4497a00e48c6f4561af')
prepare() {
cd ${srcdir}/photutils-${pkgver}
- sed -i -e '/auto_use/s/True/False/' setup.cfg
- cp -a ${srcdir}/photutils-${pkgver}{,-py2}
+ sed -i -e '/auto_use/s/True/False/' setup.cfg
}
-build () {
- msg "Building Python2"
- cd ${srcdir}/photutils-${pkgver}-py2
- python2 setup.py build --use-system-libraries --offline
-
- msg "Building Python3"
+build() {
cd ${srcdir}/photutils-${pkgver}
python setup.py build --use-system-libraries --offline
@@ -32,36 +26,17 @@ build () {
python setup.py build_docs
}
-#check(){
-# cd $srcdir/photutils-${pkgver}
-# python setup.py test
-#
-# cd $srcdir/photutils-${pkgver}-py2
-# python2 setup.py test
-#}
-
-package_python2-photutils() {
- depends=('python2>=2.7' 'python2-numpy>=1.9' 'python2-astropy>=2.0' 'python2-six')
- optdepends=('python2-scipy>=0.16: For full functionality'
- 'python2-scikit-image>=0.11: For full functionality'
- 'python2-scikit-learn>=0.18: For full functionality'
- 'python2-matplotlib>=1.3: For full functionality'
- 'python2-pytest: For testing'
- 'python-photutils-doc: Documentation for python-photutils')
- cd ${srcdir}/photutils-${pkgver}-py2
-
- install -D -m644 LICENSE.rst -t "${pkgdir}/usr/share/licenses/${pkgname}"
- install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
- python2 setup.py install --root=${pkgdir} --prefix=/usr --optimize=1 --use-system-libraries --offline
+check() {
+ cd ${srcdir}/photutils-${pkgver}
+ python setup.py test
}
package_python-photutils() {
- depends=('python>=3.4' 'python-numpy>=1.9' 'python-astropy>=2.0' 'python-six')
+ depends=('python>=3.5' 'python-numpy>=1.10' 'python-astropy>=2.0' 'python-six')
optdepends=('python-scipy>=0.16: For full functionality'
'python-scikit-image>=0.11: For full functionality'
'python-scikit-learn>=0.18: For full functionality'
'python-matplotlib>=1.3: For full functionality'
- 'python-pytest-astropy: For testing'
'python-photutils-doc: Documentation for python-photutils')
cd ${srcdir}/photutils-${pkgver}