summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpacosalces2020-09-17 12:08:52 -0700
committerpacosalces2020-09-17 12:08:52 -0700
commit1abef133dc39141d90af06ce0397ddefbbaea6ac (patch)
treefca168b6064c14fa2043ba185ad3dd6daee62212
downloadaur-1abef133dc39141d90af06ce0397ddefbbaea6ac.tar.gz
first commit for python-physunits
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..178ddc427c39
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-physunits
+ pkgdesc = Physical units as global variables for simple numerical propagation
+ pkgver = 0.0.3
+ pkgrel = 1
+ url = https://pypi.org/project/physunits/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-numpy
+ source = https://files.pythonhosted.org/packages/source/p/physunits/physunits-0.0.3.tar.gz
+ sha256sums = e95204f688e1ed41602baf4e021ea021c0807bf00d4c2fea94c730f641feab51
+
+pkgname = python-physunits
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02fcee459a86
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Francisco Salces Carcoba <pacosalces@gmail.com>
+pkgname=python-physunits
+_name=physunits
+pkgver=0.0.3
+pkgrel=1
+pkgdesc="Physical units as global variables for simple numerical propagation"
+license=("MIT")
+url="https://pypi.org/project/physunits/"
+makedepends=('python-setuptools')
+depends=('python-numpy')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('e95204f688e1ed41602baf4e021ea021c0807bf00d4c2fea94c730f641feab51')
+arch=('any')
+
+build() {
+ cd "$srcdir"/${_name}-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir"/${_name}-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}