summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpacosalces2020-09-17 16:44:00 -0700
committerpacosalces2020-09-17 16:44:00 -0700
commitde7f7400633a576042ef566d8d33d954d75835f8 (patch)
tree05c0acf622d258620698ec6b2c17b8fe7ddc006d
parent6bcffa08574c7961e8d39c7eeb4572b4a60d2162 (diff)
downloadaur-de7f7400633a576042ef566d8d33d954d75835f8.tar.gz
include LICENSE
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8d5eeecbf02..6c181d1c5852 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-physunits
pkgdesc = Physical units as global variables for simple numerical propagation
- pkgver = 0.0.3
- pkgrel = 1
+ pkgver = 0.0.5
+ pkgrel = 2
url = https://pypi.org/project/physunits/
arch = any
license = MIT
makedepends = python-setuptools
depends = python-numpy
- source = https://files.pythonhosted.org/packages/source/p/physunits/physunits-0.0.3.tar.gz
- sha256sums = 22e785c7cdf503004d3bb2309d45c466666e88a215afffd8bf3b0e7d5d307603
+ source = https://files.pythonhosted.org/packages/source/p/physunits/physunits-0.0.5.tar.gz
+ sha256sums = c2f47c6dba054422fb3d78fafe156dae718d4b05006cf33141d90c12b8f45430
pkgname = python-physunits
diff --git a/PKGBUILD b/PKGBUILD
index abe48ec0b90a..c22e42052c0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Francisco Salces Carcoba <pacosalces@gmail.com>
pkgname=python-physunits
_name=physunits
-pkgver=0.0.3
-pkgrel=1
+pkgver=0.0.5
+pkgrel=2
pkgdesc="Physical units as global variables for simple numerical propagation"
license=("MIT")
url="https://pypi.org/project/physunits/"
makedepends=('python-setuptools')
depends=('python-numpy')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('22e785c7cdf503004d3bb2309d45c466666e88a215afffd8bf3b0e7d5d307603')
+sha256sums=('c2f47c6dba054422fb3d78fafe156dae718d4b05006cf33141d90c12b8f45430')
arch=('any')
build() {
@@ -20,4 +20,5 @@ build() {
package() {
cd "$srcdir"/${_name}-$pkgver
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 "LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}