summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-02-06 12:41:16 -0500
committerGuillaume Horel2019-02-06 12:41:16 -0500
commit46f9af2defe7429b8dca1849cf851c9b048aa88d (patch)
tree50e7929379d7a2f59ea62b3f540b8866033924c5
downloadaur-46f9af2defe7429b8dca1849cf851c9b048aa88d.tar.gz
initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32b822a6064c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pickle5
+ pkgdesc = Experimental backport of the pickle 5 protocol (PEP 574)
+ pkgver = 0.0.6
+ pkgrel = 1
+ url = https://github.com/pitrou/pickle5-backport
+ arch = any
+ license = custom
+ makedepends = python-setuptools
+ depends = python
+ source = https://pypi.org/packages/source/p/pickle5/pickle5-0.0.6.tar.gz
+ sha256sums = ae0022ad79930cf8cd190eade903ec5041c36a0237bab8ac38a50d2c9d3fc3cb
+
+pkgname = python-pickle5
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d878843948d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname=('python-pickle5')
+_pkgname='pickle5'
+pkgver='0.0.6'
+pkgrel=1
+pkgdesc="Experimental backport of the pickle 5 protocol (PEP 574)"
+url="https://github.com/pitrou/pickle5-backport"
+depends=('python')
+checkdepends=()
+makedepends=('python-setuptools')
+license=('custom')
+arch=('any')
+source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('ae0022ad79930cf8cd190eade903ec5041c36a0237bab8ac38a50d2c9d3fc3cb')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}