summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormatteo2016-01-28 15:18:12 +0100
committermatteo2016-01-28 15:18:12 +0100
commit24c36f984bf6b4f0f735e818a43844158c866332 (patch)
tree28c21a9c493d47bfef6845362c4bf2c1a802e5ff
downloadaur-24c36f984bf6b4f0f735e818a43844158c866332.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--LICENSE26
-rw-r--r--PKGBUILD55
3 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5b7f7689a4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Thu Jan 28 14:12:39 UTC 2016
+pkgbase = python-pickledb
+ pkgdesc = pickleDB is lightweight, fast, and simple database based on Python’s own json module
+ pkgver = 0.4
+ pkgrel = 1
+ url = http://packages.python.org/pickleDB/
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = https://pypi.python.org/packages/source/p/pickleDB/pickleDB-0.4.tar.gz
+ source = LICENSE
+ md5sums = 91e0147b371576963a8057852aa9c309
+ md5sums = 173f7ea52700eee04c0d48eb75d6f1cf
+
+pkgname = python-pickledb
+ depends = python-simplejson
+
+pkgname = python2-pickledb
+ depends = python2-simplejson
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..76e7c2730fd5
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,26 @@
+Full License Text
+The BSD 3-Clause License The following is a BSD 3-Clause ("BSD New" or "BSD Simplified") license template. To generate your own license, change the values of OWNER, ORGANIZATION and YEAR from their original values as given here, and substitute your own.
+
+Note: You may omit clause 3 and still be OSD-conformant. Despite its colloquial name "BSD New", this is not the newest version of the BSD license; it was followed by the even newer BSD-2-Clause version, sometimes known as the "Simplified BSD License". On January 9th, 2008 the OSI Board approved BSD-2-Clause, which is used by FreeBSD and others. It omits the final "no-endorsement" clause and is thus roughly equivalent to the MIT License.
+
+Historical Background: The original license used on BSD Unix had four clauses. The advertising clause (the third of four clauses) required you to acknowledge use of U.C. Berkeley code in your advertising of any product using that code. It was officially rescinded by the Director of the Office of Technology Licensing of the University of California on July 22nd, 1999. He states that clause 3 is "hereby deleted in its entirety." The four clause license has not been approved by OSI. The license below does not contain the advertising clause.
+
+This prelude is not part of the license.
+
+OWNER = Regents of the University of California
+
+ORGANIZATION = University of California, Berkeley
+
+YEAR = 1998
+
+In the original BSD license, both occurrences of the phrase "COPYRIGHT HOLDERS AND CONTRIBUTORS" in the disclaimer read "REGENTS AND CONTRIBUTORS".
+
+License template
+Copyright (c) $YEAR $OWNER, All rights reserved.
+
+Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
+
+Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
+Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
+Neither the name of the copyright holder nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d228aab58bf5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# $Id$
+# Maintainer: Matteo Triggiani <davvore33@gmail.com>
+# Contributor:
+pkgname=('python-pickledb' 'python2-pickledb')
+pkgver=0.4
+pkgrel=1
+pkgdesc='pickleDB is lightweight, fast, and simple database based on Python’s own json module'
+url='http://packages.python.org/pickleDB/'
+arch=('any')
+license=('BSD')
+makedepends=('python-setuptools' 'python2-setuptools')
+source=("https://pypi.python.org/packages/source/p/pickleDB/pickleDB-$pkgver.tar.gz" "LICENSE")
+md5sums=('91e0147b371576963a8057852aa9c309' '173f7ea52700eee04c0d48eb75d6f1cf')
+prepare() {
+ cp -r "pickleDB-$pkgver" "python-pickledb-$pkgver"
+ cp -r "pickleDB-$pkgver" "python2-pickledb-$pkgver"
+}
+
+build_python-pickledb() {
+ cd "$pkgname-$pkgver"
+
+ python setup.py build
+}
+
+build_python2-pickledb() {
+ cd "$pkgname-$pkgver"
+
+ python2 setup.py build
+}
+
+check_python-pickledb() {
+ cd "$pkgname-$pkgver"
+ python setup.py test
+
+ cd "$pkgname-$pkgver"
+ python2 setup.py test
+}
+
+package_python-pickledb() {
+ depends=('python-simplejson')
+ cd "$pkgname-$pkgver"
+
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ install -Dm644 "${srcdir}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+package_python2-pickledb() {
+ depends=('python2-simplejson')
+ cd "$pkgname-$pkgver"
+
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 "${srcdir}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: