summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaximilian Stahlberg2018-08-28 16:26:03 +0200
committerMaximilian Stahlberg2018-08-28 16:26:03 +0200
commit8b0cc7c2c64868755b1e1540456dfa9769d08515 (patch)
tree424ee4007a34e32acd5a3c049b2f855bf1c14a61
downloadaur-8b0cc7c2c64868755b1e1540456dfa9769d08515.tar.gz
Initial package.
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD35
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7bbecebd010
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Tue Aug 28 14:24:46 UTC 2018
+pkgbase = python-picos-git
+ pkgdesc = A Python interface to conic optimization solvers. Git version.
+ pkgver = 1.1.2.r110.ga27c1f8
+ pkgrel = 1
+ url = https://gitlab.com/picos-api/picos
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = picos::git+https://gitlab.com/picos-api/picos.git
+ md5sums = SKIP
+
+pkgname = python-picos-git
+ depends = python-six
+ depends = python-numpy
+ depends = python-cvxopt
+ conflicts = python-picos
+
+pkgname = python2-picos-git
+ depends = python2-six
+ depends = python2-numpy
+ depends = python2-cvxopt
+ conflicts = python2-picos
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..85ec4b9241cc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg
+/src
+/picos
+*.tar.gz
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f1a39886eb4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Maximilian Stahlberg <maximilian.stahlberg tu-berlin de>
+
+pkgbase=('python-picos-git')
+pkgname=('python-picos-git' 'python2-picos-git')
+pkgver=1.1.2.r110.ga27c1f8
+pkgrel=1
+pkgdesc='A Python interface to conic optimization solvers. Git version.'
+arch=('any')
+url='https://gitlab.com/picos-api/picos'
+license=('GPL3')
+makedepends=('git' 'python-setuptools' 'python2-setuptools')
+source=("picos::git+https://gitlab.com/picos-api/picos.git")
+
+pkgver() {
+ cd picos
+ ./version.py --aur
+}
+
+package_python-picos-git() {
+ depends=('python-six' 'python-numpy' 'python-cvxopt')
+ conflicts=('python-picos')
+
+ cd picos
+ python setup.py install --root=${pkgdir}
+}
+
+package_python2-picos-git() {
+ depends=('python2-six' 'python2-numpy' 'python2-cvxopt')
+ conflicts=('python2-picos')
+
+ cd picos
+ python2 setup.py install --root=${pkgdir}
+}
+
+md5sums=('SKIP')