summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjmcb2023-01-08 20:29:32 +0000
committerjmcb2023-01-08 20:29:32 +0000
commit488cbe0ca5e1a6060638e8b890cbb82af9eb6615 (patch)
tree9163a4ccc5ce88e2d8abdd4458b047858b2767dc
downloadaur-488cbe0ca5e1a6060638e8b890cbb82af9eb6615.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore15
-rw-r--r--PKGBUILD33
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72362ff1e6e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-picotool-git
+ pkgdesc = Tools and Python libraries for manipulating Pico-8 game files.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/dansanderson/picotool
+ arch = any
+ license = MIT
+ checkdepends = flake8
+ checkdepends = mypy
+ checkdepends = python-pytest
+ makedepends = git
+ makedepends = python-pytest-runner
+ depends = python
+ depends = python-pypng
+ provides = python-picotool
+ conflicts = python-picotool
+ source = git+https://github.com/dansanderson/picotool.git
+ sha256sums = SKIP
+
+pkgname = python-picotool-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5c508a763fd1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,15 @@
+picotool/
+
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..add1a2b63078
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: jmcb <joelsgp@protonmail.com>
+
+pkgname=python-picotool-git
+_name=picotool
+pkgver=0.1
+pkgrel=1
+pkgdesc="Tools and Python libraries for manipulating Pico-8 game files. "
+arch=('any')
+url="https://github.com/dansanderson/picotool"
+license=('MIT')
+depends=('python' 'python-pypng')
+makedepends=('git' 'python-pytest-runner')
+checkdepends=('flake8' 'mypy' 'python-pytest')
+optdepends=()
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+https://github.com/dansanderson/picotool.git")
+sha256sums=('SKIP')
+
+build() {
+ cd "$_name"
+ python setup.py build
+}
+
+# check() {
+# cd "$_name"
+# pytest
+# }
+
+package() {
+ cd "$_name"
+ python setup.py install --root="$pkgdir" --optimize=1
+}