summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorandalenavals2017-10-31 01:50:26 -0200
committerandalenavals2017-10-31 01:50:26 -0200
commit2b09aa81f66676ad2e372e3af207ba0a4801fd73 (patch)
tree8ff2ac5943c4e44f81bda1b9452ff96018966181
downloadaur-2b09aa81f66676ad2e372e3af207ba0a4801fd73.tar.gz
Neither python-treecorr, nor python-piff have aproved the defined tests, so this is a test released version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD57
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..542a300020a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-piff
+ pkgdesc = Piff is a Python software package for modeling the point-spread function (PSF) across multiple detectors in the full field of view
+ pkgver = r547.8b170e4
+ pkgrel = 1
+ url = https://github.com/rmjarvis/Piff
+ arch = any
+ license = BSD
+ makedepends = git
+ depends = python
+ depends = libffi
+ depends = python-cffi
+ depends = python-treecorr
+ source = python-piff-r547.8b170e4::git+https://github.com/rmjarvis/Piff
+ md5sums = SKIP
+
+pkgname = python-piff
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83b6d8be31b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Andres Alejandro Navarro Alsina <aanavarroa@unal.edu.co>
+# Contributor: M. Jarvis
+pkgname=python-piff
+pkgver=r547.8b170e4
+pkgrel=1
+#epoch=
+
+pkgdesc=" Piff is a Python software package for modeling the
+point-spread function (PSF) across multiple detectors in the full
+field of view"
+
+
+arch=('any')
+url="https://github.com/rmjarvis/Piff"
+license=('BSD')
+groups=()
+depends=('python' 'libffi' 'python-cffi' 'python-treecorr')
+makedepends=('git')
+checkdepends=()
+optdepends=()
+#provides=()
+#conflicts=()
+#replaces=()
+#backup=()
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver::git+${url}")
+#noextract=()
+md5sums=('SKIP')
+#validpgpkeys=()
+
+
+build() {
+ cd "$src"
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+
+pkgver() {
+ cd "$pkgname-$pkgver"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ cd "$src"
+ cd "$pkgname-$pkgver"
+ python setup.py install --root=${pkgdir} --prefix=/usr
+
+}