summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorandalenavals2020-05-01 02:38:03 -0300
committerandalenavals2020-05-01 02:38:03 -0300
commita68d06f16efcda9e0f40d2cf1605caeeaf1f9bd5 (patch)
tree39f5a062e266da6fbdb81470af642def6416bbb5
parent60961a91029c2410797e3e01d921496d7bd115ad (diff)
downloadaur-a68d06f16efcda9e0f40d2cf1605caeeaf1f9bd5.tar.gz
v0.4.0
-rwxr-xr-x.SRCINFO11
-rw-r--r--[-rwxr-xr-x]PKGBUILD13
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd84ce5d1dac..e338c925b6b4 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = python-piff-git
pkgdesc = Piff is a Python software package for modeling the point-spread function (PSF) across multiple detectors in the full field of view
- pkgver = v0.2.5.r0.gdee19b7
+ pkgver = v0.4.0.r0.g6916ba7
pkgrel = 1
- url = https://github.com/rmjarvis/Piff.git
+ url = https://github.com/rmjarvis/Piff
arch = any
license = BSD
checkdepends = python-nose
checkdepends = python2-nose
checkdepends = python-scikit-learn
- checkdepends = python-uncertainties
- checkdepends = python2-uncertainties
makedepends = git
makedepends = python
makedepends = libffi
@@ -19,7 +17,6 @@ pkgbase = python-piff-git
makedepends = python-yaml
makedepends = python-treecorr-git
makedepends = python-fitsio-git
- makedepends = python-lmfit-git
makedepends = python-matplotlib
makedepends = python2
makedepends = python2-cffi
@@ -28,7 +25,6 @@ pkgbase = python-piff-git
makedepends = python2-yaml
makedepends = python2-treecorr-git
makedepends = python2-fitsio-git
- makedepends = python2-lmfit-git
makedepends = python2-matplotlib
makedepends = python-galsim-git
makedepends = python2-galsim-git
@@ -39,9 +35,10 @@ pkgbase = python-piff-git
optdepends = python2-piff
optdepends = python2-pyaml
optdepends = python2-yaml
+ optdepends = python-scikit-learn
conflicts = python-piff
conflicts = python2-piff
- source = python-piff-git::git+https://github.com/rmjarvis/Piff.git#tag=v0.2.5
+ source = python-piff-git::git+https://github.com/rmjarvis/Piff#tag=v0.4.0
md5sums = SKIP
pkgname = python-piff-git
diff --git a/PKGBUILD b/PKGBUILD
index bf87489aea22..cf46e719928d 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,23 +5,24 @@
# Maintainer: Andres Alejandro Navarro Alsina <aanavarroa@unal.edu.co>
# Contributor: M. Jarvis
-_tag=v0.2.5
+_tag=v0.4.0
_pkgname=python-piff-git
pkgbase=python-piff-git
pkgname=('python-piff-git' 'python2-piff-git')
-pkgver=v0.2.5.r0.gdee19b7
+pkgver=v0.4.0.r0.g6916ba7
pkgrel=1
pkgdesc=" Piff is a Python software package for modeling the
point-spread function (PSF) across multiple detectors in the full
field of view"
arch=('any')
-url="https://github.com/rmjarvis/Piff.git"
+url="https://github.com/rmjarvis/Piff"
license=('BSD')
-makedepends=('git' 'python' 'libffi' 'python-cffi' 'python-numpy' 'python-scipy' 'python-yaml' 'python-treecorr-git' 'python-fitsio-git' 'python-lmfit-git' 'python-matplotlib' 'python2' 'python2-cffi' 'python2-numpy' 'python2-scipy' 'python2-yaml' 'python2-treecorr-git' 'python2-fitsio-git' 'python2-lmfit-git' 'python2-matplotlib' 'python-galsim-git' 'python2-galsim-git' 'python-coord-git' 'python2-coord-git')
-optdepends=('python2-scikit-learn' 'python-piff' 'python2-piff' 'python2-pyaml' 'python2-yaml')
-checkdepends=('python-nose' 'python2-nose' 'python-scikit-learn' 'python-uncertainties' 'python2-uncertainties' )
+makedepends=('git' 'python' 'libffi' 'python-cffi' 'python-numpy' 'python-scipy' 'python-yaml' 'python-treecorr-git' 'python-fitsio-git' 'python-matplotlib' 'python2' 'python2-cffi' 'python2-numpy' 'python2-scipy' 'python2-yaml' 'python2-treecorr-git' 'python2-fitsio-git' 'python2-matplotlib' 'python-galsim-git' 'python2-galsim-git' 'python-coord-git' 'python2-coord-git')
+optdepends=('python2-scikit-learn' 'python-piff' 'python2-piff' 'python2-pyaml' 'python2-yaml' 'python-scikit-learn')
+checkdepends=('python-nose' 'python2-nose' 'python-scikit-learn')
conflicts=('python-piff' 'python2-piff')
source=("${pkgbase}::git+${url}#tag=$_tag")
+#source=("${pkgbase}::git+${url}")
md5sums=('SKIP')
pkgver() {