summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Lubineau2011-11-11 12:33:43 +0100
committerAntoine Lubineau2011-11-11 12:33:43 +0100
commita7775cb12739482401df86c23c2b14080125830e (patch)
tree9ce00f83a87a6c172d4d5ba825702eb1642efc41
downloadaur-python-pigment-svn.tar.gz
Packages adopted from wido
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore0
-rw-r--r--PKGBUILD41
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b3f20599a37
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-pigment-svn
+ pkgdesc = Development version of Pigment Python library and bindings.
+ pkgver = 1557
+ pkgrel = 1
+ url = https://code.fluendo.com/pigment/trac
+ arch = any
+ license = GPL
+ makedepends = subversion
+ depends = pigment-svn
+ depends = python
+ depends = pygobject
+ conflicts = python-pigment
+ conflicts = pigment-python-svn
+ options = !libtool
+
+pkgname = python-pigment-svn
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0654ed1f3e4b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Contributor: Jon Kristian Nilsen <jokr.nilsen@gmail.com>
+
+pkgname=python-pigment-svn
+pkgver=1557
+pkgrel=1
+pkgdesc="Development version of Pigment Python library and bindings."
+url="https://code.fluendo.com/pigment/trac"
+arch=(any)
+license=('GPL')
+
+depends=('pigment-svn' 'python' 'pygobject')
+makedepends=('subversion')
+conflicts=('python-pigment' 'pigment-python-svn')
+options=('!libtool')
+
+_svntrunk="https://code.fluendo.com/pigment/svn/trunk/pigment-python"
+_svnmod="pigment-python"
+
+build() {
+ cd ${srcdir}
+
+ if [ -d $_svnmod/.svn ]; then
+ (cd $_svnmod && svn up -r $pkgver)
+ else
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ fi
+
+ msg "SVN checkout done or server timeout"
+ msg "Starting make..."
+
+ cp -r $_svnmod $_svnmod-build
+ cd $_svnmod-build
+
+ ./autogen.sh --prefix=/usr
+ make || return 1
+ make DESTDIR=${pkgdir} install
+
+ rm -rf ${srcdir}/$_svnmod-build
+}
+
+# vim:syntax=sh